summaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorRaghav Gururajan <rg@raghavgururajan.name>2021-07-20 07:54:56 -0400
committerRaghav Gururajan <rg@raghavgururajan.name>2021-07-20 07:54:56 -0400
commite644e45aec26dc2069c18ec9fb6e96b8e4af59f3 (patch)
treeabd811e252320f05c5b2e1ef6a01a8530010af3f /gnu/packages/video.scm
parent7b9c4417d54009efd9140860ce07dec97120676f (diff)
downloadguix-patches-e644e45aec26dc2069c18ec9fb6e96b8e4af59f3.tar
guix-patches-e644e45aec26dc2069c18ec9fb6e96b8e4af59f3.tar.gz
gnu: pipe-viewer: Correct references to youtube-dl program.
* gnu/packages/videos.scm (pipe-viewer)[phases](patch-source): Modify.
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index f19bdc7ef6..399327741f 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -1055,7 +1055,11 @@ H.264 (MPEG-4 AVC) video streams.")
(modify-phases %standard-phases
(add-after 'unpack 'patch-source
(lambda* (#:key inputs #:allow-other-keys)
- (substitute* (find-files "." ".*-viewer$")
+ (substitute* (find-files "lib" "\\.pm$")
+ (("\"youtube-dl\"")
+ (format #f "\"~a/bin/youtube-dl\""
+ (assoc-ref inputs "youtube-dl"))))
+ (substitute* (find-files "bin" ".*-viewer$")
(("'ffmpeg'")
(format #f "'~a/bin/ffmpeg'"
(assoc-ref inputs "ffmpeg")))