summaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-05-30 11:51:30 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-05-30 11:53:00 +0200
commitc00b1760f605255719a525e52c268b222a1f5184 (patch)
tree9b79d7f16cc3992cdac82ebbc21193059b55e434 /gnu/packages/video.scm
parentae303853d447018a98d0ec7663ccde969d87302d (diff)
downloadguix-patches-c00b1760f605255719a525e52c268b222a1f5184.tar
guix-patches-c00b1760f605255719a525e52c268b222a1f5184.tar.gz
gnu: vapoursynth: Wrap with own PYTHONPATH.
This fixes, e.g., ‘vspipe -v’ in a pure environment. * gnu/packages/video.scm (vapoursynth)[arguments]: Add a 'wrap phase. Reported by maddo of #guix.
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm12
1 files changed, 12 insertions, 0 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 2eef76558a..5975004049 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -2817,6 +2817,18 @@ capabilities.")
(base32
"1krfdzc2x2vxv4nq9kiv1c09hgj525qn120ah91fw2ikq8ldvmx4"))))
(build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'wrap
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (site (string-append out "/lib/python"
+ ,(version-major+minor
+ (package-version python))
+ "/site-packages")))
+ (wrap-program (string-append out "/bin/vspipe")
+ `("PYTHONPATH" ":" = (,site)))))))))
(native-inputs
`(("autoconf" ,autoconf)
("automake" ,automake)