summaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorArne Babenhauserheide <arne_bab@web.de>2019-03-05 16:58:32 -0500
committerLeo Famulari <leo@famulari.name>2019-03-05 18:29:20 -0500
commita7afa45401164b78757536bbe95ecc70100d62ac (patch)
tree243402f1d8895491cfbb9e06c7145b578199d36e /gnu/packages/video.scm
parentdbfa3bb5d0450422ba7faf420fe96faabfb84236 (diff)
downloadguix-patches-a7afa45401164b78757536bbe95ecc70100d62ac.tar
guix-patches-a7afa45401164b78757536bbe95ecc70100d62ac.tar.gz
gnu: Add libaom.
* gnu/packages/video.scm (libaom): New variable. Co-authored-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index edaaed67c9..4f864a6502 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -33,6 +33,7 @@
;;; Copyright © 2018 Gábor Boskovit <boskovits@gmail.com>
;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2019 Timo Eisenmann <eisenmann@fn.de>
+;;; Copyright © 2019 Arne Babenhauserheide <arne_bab@web.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -240,6 +241,43 @@ A/52 standard is used in a variety of applications, including digital
television and DVD. It is also known as AC-3.")
(license license:gpl2+)))
+(define-public libaom
+ ;; The 1.0.0-errata1 release installs a broken pkg-config .pc file. This
+ ;; is fixed in libaom commit 0ddc150, but we use an even later commit.
+ (let ((commit "22b150bf040608028a56d8bf39e72f771383d836")
+ (revision "0"))
+ (package
+ (name "libaom")
+ (version (git-version "1.0.0-errata1" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://aomedia.googlesource.com/aom/")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1pdd5h3n42607n6qmggz4yv8izhjr2kl6knb3kh7gh4v0vy47h1r"))))
+ (build-system cmake-build-system)
+ (native-inputs
+ `(("perl" ,perl)
+ ("pkg-config" ,pkg-config)
+ ("python" ,python))) ; to detect the version
+ (arguments
+ `(#:tests? #f ;no check target
+ #:configure-flags
+ ;; build dynamic library
+ (list "-DBUILD_SHARED_LIBS=YES"
+ "-DENABLE_PIC=TRUE"
+ "-DAOM_TARGET_CPU=generic"
+ (string-append "-DCMAKE_INSTALL_PREFIX="
+ (assoc-ref %outputs "out")))))
+ (home-page "https://aomedia.googlesource.com/aom/")
+ (synopsis "AV1 video codec")
+ (description "Libaom is the reference implementation of AV1. It includes
+a shared library and encoder and decoder command-line executables.")
+ (license license:bsd-2))))
+
(define-public libmpeg2
(package
(name "libmpeg2")