summaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-08-30 22:22:51 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-08-30 22:22:51 +0200
commit552c3e95f3f6344ed4d91c975798194fed380d14 (patch)
treef02dda86a70cdf22c23c0aaa3845ce4145a09653 /gnu/packages/video.scm
parent2de7d137b3c6f528acb540a6ab3460627f484b0a (diff)
downloadguix-patches-552c3e95f3f6344ed4d91c975798194fed380d14.tar
guix-patches-552c3e95f3f6344ed4d91c975798194fed380d14.tar.gz
gnu: vlc: Build with modular qt.
* gnu/packages/video.scm (vlc)[inputs]: Remove QT. Add QTBASE and QTX11EXTRAS. [arguments]: Add CXXFLAGS=-std=gnu++11 to #:configure-flags. Add 'fix-qt-include' phase.
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm12
1 files changed, 9 insertions, 3 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index ce23e51417..f485f7d3c4 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -819,9 +819,8 @@ audio/video codec library.")
("perl" ,perl)
("pulseaudio" ,pulseaudio)
("python" ,python-wrapper)
- ("qt" ,qt) ; FIXME: reenable modular qt after update - requires building
- ;("qtbase" ,qtbase) with -std=gnu++11.
- ;("qtx11extras" ,qtx11extras)
+ ("qtbase" ,qtbase)
+ ("qtx11extras" ,qtx11extras)
("sdl" ,sdl)
("sdl-image" ,sdl-image)
("speex" ,speex)
@@ -833,6 +832,7 @@ audio/video codec library.")
;; In our case, this led to a test failure:
;; test_libvlc_equalizer: libvlc/equalizer.c:122: test_equalizer: Assertion `isnan(libvlc_audio_equalizer_get_amp_at_index (equalizer, u_bands))' failed.
"ac_cv_c_fast_math=no"
+ "CXXFLAGS=-std=gnu++11"
,(string-append "LDFLAGS=-Wl,-rpath -Wl,"
(assoc-ref %build-inputs "ffmpeg")
@@ -856,6 +856,12 @@ audio/video codec library.")
(substitute* "test/run_vlc.sh"
(("./vlc --ignore-config") "echo"))
#t))
+ (add-before 'build 'fix-qt-include
+ (lambda _
+ ;; XXX Likely not needed for >2.2.6.
+ (substitute* "modules/gui/qt4/components/interface_widgets.cpp"
+ (("<qx11info_x11.h>") "<QtX11Extras/qx11info_x11.h>"))
+ #t))
(add-after 'install 'regenerate-plugin-cache
(lambda* (#:key outputs #:allow-other-keys)
;; The 'install-exec-hook' rule in the top-level Makefile.am