summaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-07-16 16:01:49 +0200
committerLudovic Courtès <ludo@gnu.org>2021-07-24 16:23:23 +0200
commit425ccde6ae7bd4b448ee2fffd8c0b6b7bcbb543c (patch)
tree145a510a65828591121aa5a24f8e2aeca0986ed1 /gnu/packages/video.scm
parentd76b2f82af738ef4c006fba9efd30c28e3d76736 (diff)
downloadguix-patches-425ccde6ae7bd4b448ee2fffd8c0b6b7bcbb543c.tar
guix-patches-425ccde6ae7bd4b448ee2fffd8c0b6b7bcbb543c.tar.gz
gnu: Use 'search-input-directory' when looking for C/C++ library headers.
* gnu/packages/arcan.scm (arcan)[arguments]: Use 'search-input-directory' for "include/libdrm" and "include/apr-1". * gnu/packages/bioinformatics.scm (sailfish): Likewise for jellyfish. * gnu/packages/boost.scm (boost-for-irods): Likewise for libcxx headers. * gnu/packages/cedille.scm (cedille): Likewise for IAL headers. * gnu/packages/compression.scm (snappy-with-clang6): Likewise for libcxx headers. * gnu/packages/cups.scm (hplip): Likewise for libusb headers. * gnu/packages/emulators.scm (pcsxr): Likewise for libcdio headers. * gnu/packages/game-development.scm (python2-renpy): Likewise for fribidi headers. * gnu/packages/games.scm (pokerth): Likewise for libircclient. * gnu/packages/guile-xyz.scm (guile-persist): Likewise for Guile. * gnu/packages/hurd.scm (hurd): Likewise for libtirpc. * gnu/packages/irods.scm (irods, irods-client-icommands): Likewise for libcxx, catch2, and nlohmann-json-cpp. * gnu/packages/julia.scm (julia): Use 'search-input-file' for libuv's errno.h. * gnu/packages/kde-pim.scm (kdepim-runtime): Use 'search-input-directory' for "include/KF5". (kmessagelib): Likewise. * gnu/packages/kde.scm (kdeconnect): Likewise. * gnu/packages/llvm.scm (clang-runtime-3.5): Likewise for libtirpc. * gnu/packages/mpi.scm (openmpi): Likewise for "include/infiniband". * gnu/packages/pumpio.scm (pumpa): Use 'search-input-file' for "tidy.h" and "aspell.h". * gnu/packages/radio.scm (dream): Use 'search-input-file' and 'search-input-directory' for pulseaudio, sndfile, etc. * gnu/packages/selinux.scm (policycoreutils): Likewise for PAM and libaudit. * gnu/packages/serialization.scm (avro-cpp-1.9-for-irods): Likewise for libcxx. * gnu/packages/sync.scm (nextcloud-client): Likewise for "include/KF5". * gnu/packages/video.scm (mkvtoolnix): Likewise for "include/gtest". (libopenshot): Likewise for "include/UnitTest++". * gnu/packages/virtualization.scm (criu): Likewise for libnl3 and for protobuf file.
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm11
1 files changed, 4 insertions, 7 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 3f7d34ef59..b2bb7b8d3b 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -977,10 +977,8 @@ H.264 (MPEG-4 AVC) video streams.")
#t)))
(add-before 'configure 'add-googletest
(lambda* (#:key inputs #:allow-other-keys)
- (symlink
- (string-append (assoc-ref inputs "googletest")
- "/include/gtest") "lib/gtest")
- #t))
+ (symlink (search-input-file inputs "/include/gtest")
+ "lib/gtest")))
(replace 'build
(lambda _
(let ((-j (list "-j" (number->string (parallel-job-count)))))
@@ -4597,9 +4595,8 @@ create smoother and stable videos.")
(setenv "ZMQDIR"
(assoc-ref inputs "zeromq"))
(setenv "UNITTEST_DIR"
- (string-append (assoc-ref inputs "unittest++")
- "/include/UnitTest++"))
- #t)))))
+ (search-input-directory inputs
+ "include/UnitTest++")))))))
(home-page "https://openshot.org")
(synopsis "Video-editing, animation, and playback library")
(description "OpenShot Library (libopenshot) is a powerful C++ video