summaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-09-04 22:34:28 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-09-04 22:34:28 +0200
commita76585e5535f433d37c0900cf0b2d3c9d3b3461c (patch)
tree007befec20e2a33117256eeee11b7c642179dad4 /gnu/packages/video.scm
parent1dc32c2961402c946c25e5a1aabe79a30cce3cff (diff)
parentc427fda233a7da0c8eb27e244a562c51d3835503 (diff)
downloadguix-patches-a76585e5535f433d37c0900cf0b2d3c9d3b3461c.tar
guix-patches-a76585e5535f433d37c0900cf0b2d3c9d3b3461c.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 7a673a89fb..65e8e1965b 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -2257,9 +2257,9 @@ practically any type of media.")
(add-before 'configure 'pre-configure
(lambda _
(chdir "Project/GNU/Library")))
- (add-before 'configure 'autogen
+ (add-after 'unpack 'autogen
(lambda _
- (zero? (system* "./autogen.sh")))))))
+ (zero? (system* "sh" "autogen.sh")))))))
(home-page "https://mediaarea.net/en/MediaInfo")
(synopsis "Library for retrieving media metadata")
(description "MediaInfo is a library used for retrieving technical
@@ -2315,9 +2315,9 @@ MPEG-2, MPEG-4, DVD (VOB)...
(add-before 'configure 'pre-configure
(lambda _
(chdir "Project/GNU/CLI")))
- (add-before 'configure 'autogen
+ (add-after 'unpack 'autogen
(lambda _
- (zero? (system* "./autogen.sh")))))))
+ (zero? (system* "sh" "autogen.sh")))))))
(home-page "https://mediaarea.net/en/MediaInfo")
(synopsis "Utility for reading media metadata")
(description "MediaInfo is a utility used for retrieving technical