summaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2016-08-04 08:16:38 -0400
committerMark H Weaver <mhw@netris.org>2016-08-04 08:16:38 -0400
commit0832787e5c463c713d8f24fdec0f52900ff1c2bd (patch)
tree5ce20bef711d0d85a22cd041758278d7c176b0f3 /gnu/packages/video.scm
parent5b098cc4b937c05d6f685772c66e2aa04490710a (diff)
downloadguix-patches-0832787e5c463c713d8f24fdec0f52900ff1c2bd.tar
guix-patches-0832787e5c463c713d8f24fdec0f52900ff1c2bd.tar.gz
Revert "Merge branch 'core-updates'"
This reverts commit 455859a50f88f625d13fc2f304111f02369b366b.
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm12
1 files changed, 3 insertions, 9 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index e3da8f1b46..7089c99665 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -330,7 +330,7 @@ SMPTE 314M.")
(define-public libva
(package
(name "libva")
- (version "1.7.0")
+ (version "1.6.1")
(source
(origin
(method url-fetch)
@@ -338,7 +338,7 @@ SMPTE 314M.")
"https://www.freedesktop.org/software/vaapi/releases/libva/libva-"
version".tar.bz2"))
(sha256
- (base32 "0py9igf4kicj7ji22bjawkpd6my013qpg0s4ir2np9l1rk5vr2d6"))))
+ (base32 "0bjfb5s8dk3lql843l91ffxzlq47isqks5sj19cxh7j3nhzw58kz"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)))
@@ -369,7 +369,7 @@ SMPTE 314M.")
#:make-flags
(list (string-append "dummy_drv_video_ladir="
(assoc-ref %outputs "out") "/lib/dri"))))
- (home-page "https://www.freedesktop.org/wiki/Software/vaapi/")
+ (home-page "http://www.freedesktop.org/wiki/Software/vaapi/")
(synopsis "Video acceleration library")
(description "The main motivation for VA-API (Video Acceleration API) is
to enable hardware accelerated video decode/encode at various
@@ -625,12 +625,6 @@ audio/video codec library.")
(arguments
`(#:configure-flags
`("--disable-a52" ; FIXME: reenable once available
-
- ;; Gross workaround for <https://trac.videolan.org/vlc/ticket/16907>.
- ;; In our case, this led to a test failure:
- ;; test_libvlc_equalizer: libvlc/equalizer.c:122: test_equalizer: Assertion `isnan(libvlc_audio_equalizer_get_amp_at_index (equalizer, u_bands))' failed.
- "ac_cv_c_fast_math=no"
-
,(string-append "LDFLAGS=-Wl,-rpath -Wl,"
(assoc-ref %build-inputs "ffmpeg")
"/lib")) ;needed for the tests