summaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-10-13 23:39:27 +0200
committerMarius Bakke <marius@gnu.org>2020-10-13 23:39:27 +0200
commitf7175626ffce578be1bc6df4916a129f86557872 (patch)
tree2eb0040522f2883764b3e09dc36595d68eeb14c1 /gnu/packages/video.scm
parent2b6ecdf41a09ab9ecae06d7c537583a2f0f28efc (diff)
parente8c5533d26b4441c96e9ae92350efcb24d787c4b (diff)
downloadguix-patches-f7175626ffce578be1bc6df4916a129f86557872.tar
guix-patches-f7175626ffce578be1bc6df4916a129f86557872.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm52
1 files changed, 35 insertions, 17 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 0b02ad00b9..a8f20bf11c 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -526,7 +526,7 @@ applications by providing high-level classes for commonly required tasks.")
(define-public libde265
(package
(name "libde265")
- (version "1.0.6")
+ (version "1.0.7")
(source
(origin
(method git-fetch)
@@ -536,7 +536,7 @@ applications by providing high-level classes for commonly required tasks.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0ipccyavlgf7hfzx1g8bvzg62xq10vcxvwgq70r3z3j6mdvmrzjp"))))
+ (base32 "0x7g9771457z49qvzpk4iswfhq018i0mzsflv9gg8if5hjqhfdp0"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags
@@ -1455,6 +1455,8 @@ operate properly.")
("sdl" ,sdl2)
("soxr" ,soxr)
("speex" ,speex)
+ ;; FFmpeg is not yet compatible with SRT > 1.4.1.
+ ("srt" ,srt-1.4.1)
("twolame" ,twolame)
("vidstab" ,vidstab)
("x265" ,x265)
@@ -1539,6 +1541,7 @@ operate properly.")
'())
"--enable-libsoxr"
"--enable-libspeex"
+ "--enable-libsrt"
"--enable-libtheora"
"--enable-libtwolame"
"--enable-libvidstab"
@@ -1830,6 +1833,8 @@ videoformats depend on the configuration flags of ffmpeg.")
("sdl-image" ,sdl-image)
("speex" ,speex)
("speexdsp" ,speexdsp)
+ ;; VLC is not yet compatible with SRT > 1.4.1.
+ ("srt" ,srt-1.4.1)
("taglib" ,taglib)
("twolame" ,twolame)
("unzip" ,unzip)
@@ -2129,9 +2134,8 @@ To load this plugin, specify the following option when starting mpv:
(define-public libvpx
(package
(name "libvpx")
- (version "1.8.2")
+ (version "1.9.0")
(source (origin
- ;; XXX: Upstream does not provide tarballs for > 1.6.1.
(method git-fetch)
(uri (git-reference
(url "https://chromium.googlesource.com/webm/libvpx")
@@ -2139,7 +2143,7 @@ To load this plugin, specify the following option when starting mpv:
(file-name (git-file-name name version))
(sha256
(base32
- "0gyq4fkbd2fv7m1mm9xrvn6rk6f4jsmbv8bnlhingmnrvyncnmnr"))
+ "16xv6ambc82g14h1y0q1vyy57wp6j9fbp0nk0wd5csnrw407rhry"))
(patches (search-patches "libvpx-CVE-2016-2818.patch"))))
(build-system gnu-build-system)
(arguments
@@ -2157,7 +2161,11 @@ To load this plugin, specify the following option when starting mpv:
;; The configure script does not understand some of the GNU
;; options, so we only add the flags specified above.
(apply invoke "./configure" configure-flags))))
- #:tests? #f)) ; no check target
+
+ ;; XXX: The test suite wants to download 871 files from a cloud storage
+ ;; service (see test/test-data.sha1). It is possible to specify a
+ ;; custom directory, but there seems to be no tarball with all files.
+ #:tests? #f))
(native-inputs
`(("perl" ,perl)
("yasm" ,yasm)))
@@ -2368,7 +2376,7 @@ audio, images) from the Web. It can use either mpv or vlc for playback.")
(define-public youtube-viewer
(package
(name "youtube-viewer")
- (version "3.7.8")
+ (version "3.7.9")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -2377,7 +2385,7 @@ audio, images) from the Web. It can use either mpv or vlc for playback.")
(file-name (git-file-name name version))
(sha256
(base32
- "1ckzzf35nbwlx5prvzjr52n28chyd479vhdk5w7vb2343az80mzi"))))
+ "16p0sa91h0zpqdpqmy348g6b9qj5f6qrbzrljn157vk00cg6mx18"))))
(build-system perl-build-system)
(native-inputs
`(("perl-module-build" ,perl-module-build)))
@@ -2390,6 +2398,7 @@ audio, images) from the Web. It can use either mpv or vlc for playback.")
("perl-libwww" ,perl-libwww)
("perl-lwp-protocol-https" ,perl-lwp-protocol-https)
("perl-lwp-useragent-cached" ,perl-lwp-useragent-cached)
+ ("perl-memoize" ,perl-memoize)
("perl-mozilla-ca" ,perl-mozilla-ca)
("perl-term-readline-gnu" ,perl-term-readline-gnu)
("perl-unicode-linebreak" ,perl-unicode-linebreak)
@@ -2996,7 +3005,7 @@ be used for realtime video capture via Linux-specific APIs.")
(define-public obs
(package
(name "obs")
- (version "26.0.0")
+ (version "26.0.2")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -3005,12 +3014,21 @@ be used for realtime video capture via Linux-specific APIs.")
(file-name (git-file-name name version))
(sha256
(base32
- "09y57b3c88szl3wyx3cxq8jrm3pfnyg2n25hxl1ynkq3rgaavdq2"))))
+ "1d502f80whh686mvq0yn6zpa5nvmnlzxwp5sjz43vpbbvhpbrdqj"))))
(build-system cmake-build-system)
(arguments
`(#:configure-flags
(list (string-append "-DOBS_VERSION_OVERRIDE=" ,version)
- "-DENABLE_UNIT_TESTS=TRUE")))
+ "-DENABLE_UNIT_TESTS=TRUE")
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'wrap-executable
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out"))
+ (plugin-path (getenv "QT_PLUGIN_PATH")))
+ (wrap-program (string-append out "/bin/obs")
+ `("QT_PLUGIN_PATH" ":" prefix (,plugin-path))))
+ #t)))))
(native-inputs
`(("cmocka" ,cmocka)
("pkg-config" ,pkg-config)))
@@ -3601,7 +3619,7 @@ practically any type of media.")
(define-public libmediainfo
(package
(name "libmediainfo")
- (version "20.08")
+ (version "20.09")
(source (origin
(method url-fetch)
(uri (string-append "https://mediaarea.net/download/source/"
@@ -3609,7 +3627,7 @@ practically any type of media.")
name "_" version ".tar.xz"))
(sha256
(base32
- "19n8h9jq42b6r3dbag77fzwfksfywszmzpi636w87fvc1nqldlqj"))))
+ "15ni9pnch6688m72swwax109a7mg4a08yx75qknrx7qa6dbyhz6h"))))
;; TODO add a Big Buck Bunny webm for tests.
(native-inputs
`(("autoconf" ,autoconf)
@@ -3659,7 +3677,7 @@ MPEG-2, MPEG-4, DVD (VOB)...
(define-public mediainfo
(package
(name "mediainfo")
- (version "20.08")
+ (version "20.09")
(source (origin
(method url-fetch)
;; Warning: This source has proved unreliable 1 time at least.
@@ -3670,7 +3688,7 @@ MPEG-2, MPEG-4, DVD (VOB)...
name "_" version ".tar.xz"))
(sha256
(base32
- "1baf2dj5s3g1x4ssqli1b2r1203syk42m09zhp36qcinmfixv11l"))))
+ "0rqg9z7s5bk7vlvjrs4gackzg7ib05a0dffi2ihsjf5a7kw7wcir"))))
(native-inputs
`(("autoconf" ,autoconf)
("automake" ,automake)
@@ -4540,7 +4558,7 @@ result in several formats:
("rust-arrayvec" ,rust-arrayvec-0.5)
("rust-backtrace" ,rust-backtrace-0.3)
("rust-bitstream-io" ,rust-bitstream-io-0.8)
- ("rust-byteorder" ,rust-byteorder-1.3)
+ ("rust-byteorder" ,rust-byteorder-1)
("rust-cfg-if" ,rust-cfg-if-0.1)
("rust-clap" ,rust-clap-2)
("rust-console" ,rust-console-0.11)
@@ -4564,7 +4582,7 @@ result in several formats:
("rust-serde" ,rust-serde-1)
("rust-signal-hook" ,rust-signal-hook-0.1)
("rust-simd-helpers" ,rust-simd-helpers-0.1)
- ("rust-thiserror" ,rust-thiserror-1.0)
+ ("rust-thiserror" ,rust-thiserror-1)
("rust-toml" ,rust-toml-0.5)
("rust-y4m" ,rust-y4m-0.5)
("rust-cc" ,rust-cc-1)