summaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorng0 <ng0@we.make.ritual.n0.is>2016-11-04 19:23:02 +0000
committerMarius Bakke <mbakke@fastmail.com>2016-11-05 12:27:12 +0000
commit05234973c79f26d7f38189b771976c3bb6643930 (patch)
tree971c9c610b020d01105e3a135ebcd12f20453e27 /gnu/packages/video.scm
parent02f8f804f0242df885311715412a1e3ee5436f3b (diff)
downloadguix-patches-05234973c79f26d7f38189b771976c3bb6643930.tar
guix-patches-05234973c79f26d7f38189b771976c3bb6643930.tar.gz
gnu: Add mps-youtube.
* gnu/packages/video.scm (mps-youtube): New variable. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 6ce03f7bcc..e7c90e13de 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -11,6 +11,7 @@
;;; Copyright © 2016 Kei Kebreau <kei@openmailbox.org>
;;; Copyright © 2016 Dmitry Nikolaev <cameltheman@gmail.com>
;;; Copyright © 2016 Andy Patterson <ajpatter@uwaterloo.ca>
+;;; Copyright © 2016 ng0 <ng0@we.make.ritual.n0.is>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1683,3 +1684,31 @@ specifications.")
(description "libaacs is a library which implements the Advanced Access
Content System specification.")
(license license:lgpl2.1+)))
+
+(define-public mps-youtube
+ (package
+ (name "mps-youtube")
+ (version "0.2.7.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/mps-youtube/mps-youtube/"
+ "archive/v" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1s7h35yx6f0szf8mm8612ic913w3v05m2kwphjfcxnpq0ammhyci"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-pafy" ,python-pafy)
+ ("python-pygobject" ,python-pygobject))) ; For mpris2 support
+ (home-page "https://github.com/mps-youtube/mps-youtube")
+ (synopsis "Terminal based YouTube player and downloader")
+ (description
+ "@code{mps-youtube} is based on mps, a terminal based program to
+search, stream and download music. This implementation uses YouTube as
+a source of content and can play and download video as well as audio.
+It can use either mpv or mplayer for playback, and for conversion of
+formats ffmpeg or libav is used. Users should install one of the
+supported players in addition to this package.")
+ (license license:gpl3+)))