summaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2018-10-15 11:33:51 +0300
committerEfraim Flashner <efraim@flashner.co.il>2018-10-15 11:40:34 +0300
commitb7028a16e6fe4f9634cd7d550b3a79450fc4e0db (patch)
treea51f6cd30133cb6d5e8915eea3446bffda57ea8c /gnu/packages/video.scm
parent2d5fa80e83190b6bdbeb8a45e68a885b283e2490 (diff)
downloadguix-patches-b7028a16e6fe4f9634cd7d550b3a79450fc4e0db.tar
guix-patches-b7028a16e6fe4f9634cd7d550b3a79450fc4e0db.tar.gz
gnu: x265: Fix building on armhf-linux and aarch64-linux.
* gnu/packages/video.scm (x265)[source]: Update list of patches. [arguments]: Change configure flag to ensure PIC for all architectures. * gnu/packages/patches/x265-arm-asm-primitives.patch: Remove file. * gnu/packages/patches/x265-detect512-all-arches.patch: New file. * gnu/local.mk (dist_patch_DATA): Update patch registry.
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm10
1 files changed, 3 insertions, 7 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index e281bf8fff..88357dfb45 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -401,7 +401,7 @@ and creating Matroska files from other media files (@code{mkvmerge}).")
(sha256
(base32
"090hp4216isis8q5gb7bwzia8rfyzni54z21jnwm97x3hiy6ibpb"))
- (patches (search-patches "x265-arm-asm-primitives.patch"))
+ (patches (search-patches "x265-detect512-all-arches.patch"))
(modules '((guix build utils)))
(snippet '(begin
(delete-file-recursively "source/compat/getopt")
@@ -409,12 +409,8 @@ and creating Matroska files from other media files (@code{mkvmerge}).")
(build-system cmake-build-system)
(arguments
`(#:tests? #f ; tests are skipped if cpu-optimized code isn't built
- ;; Currently the source code doesn't check for aarch64.
- ,@(if (any (cute string-prefix? <> (or (%current-system)
- (%current-target-system)))
- '("armhf" "aarch64"))
- '(#:configure-flags '("-DENABLE_PIC=TRUE"))
- '())
+ ;; Ensure position independent code for everyone.
+ #:configure-flags '("-DENABLE_PIC=TRUE")
#:phases
(modify-phases %standard-phases
(add-before 'configure 'prepare-build