summaryrefslogtreecommitdiff
path: root/gnu/packages/version-control.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-12-03 18:32:09 +0200
committerLudovic Courtès <ludo@gnu.org>2015-12-03 19:09:53 +0200
commitdf7393b93c3c1ad764702266016a3b640fd7fa93 (patch)
tree528e5f00051c6e4afecb2ce4c20b49b5020e37ee /gnu/packages/version-control.scm
parentdab8ebd92583781c8ed6e216396771fe4390470e (diff)
downloadguix-patches-df7393b93c3c1ad764702266016a3b640fd7fa93.tar
guix-patches-df7393b93c3c1ad764702266016a3b640fd7fa93.tar.gz
gnu: Add findnewest.
* gnu/packages/version-control.scm (findnewest): New variable.
Diffstat (limited to 'gnu/packages/version-control.scm')
-rw-r--r--gnu/packages/version-control.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index b1326634a7..a9ebd66d42 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -36,6 +36,7 @@
#:use-module (guix build-system trivial)
#:use-module (guix build utils)
#:use-module (gnu packages apr)
+ #:use-module (gnu packages autotools)
#:use-module (gnu packages asciidoc)
#:use-module (gnu packages base)
#:use-module (gnu packages bison)
@@ -925,3 +926,30 @@ any project with more than one developer, is one of Aegis's major functions.")
a history browser. It can also stage hunks for commit, or colorize the
output of the 'git' command.")
(license gpl2+)))
+
+(define-public findnewest
+ (package
+ (name "findnewest")
+ (version "0.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/0-wiz-0/findnewest/archive/findnewest-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0zlflad568y203yc5ynf1nxi2szn2pmbf1lvz6yk77kjyrpw7zxg"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:phases (modify-phases %standard-phases
+ (add-before 'configure 'bootstrap
+ (lambda _
+ (zero? (system* "autoreconf" "-vfi")))))))
+ (native-inputs `(("autoconf" ,autoconf)
+ ("automake" ,automake)))
+ (home-page "https://github.com/0-wiz-0/findnewest/releases")
+ (synopsis "Print the modification time of the latest file")
+ (description
+ "Recursively find the newest file in a file tree and print its
+modification time.")
+ (license bsd-2)))