summaryrefslogtreecommitdiff
path: root/gnu/packages/version-control.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2018-04-14 19:36:12 -0400
committerLeo Famulari <leo@famulari.name>2018-04-17 14:36:34 -0400
commit71653653ea39410d91ea7cc06cbb71790cc4da3c (patch)
tree886fda19cafc40af17cb8d67d5ff867eb6ff6778 /gnu/packages/version-control.scm
parent8366a67b0a27b2bb9190ff45d8fd97b42e0d021d (diff)
downloadguix-patches-71653653ea39410d91ea7cc06cbb71790cc4da3c.tar
guix-patches-71653653ea39410d91ea7cc06cbb71790cc4da3c.tar.gz
gnu: subversion: Update to 1.10.0.
* gnu/packages/version-control.scm (subversion): Update to 1.10.0. (arguments): Patch a hidden shebang in a new 'patch-test-sh' phase. (inputs): Add lz4 and utf8proc. Switch from python-2 to python-wrapper@3.
Diffstat (limited to 'gnu/packages/version-control.scm')
-rw-r--r--gnu/packages/version-control.scm14
1 files changed, 11 insertions, 3 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index cccdb31fb1..71ede4f549 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -90,6 +90,7 @@
#:use-module (gnu packages sdl)
#:use-module (gnu packages swig)
#:use-module (gnu packages tcl)
+ #:use-module (gnu packages textutils)
#:use-module (gnu packages time)
#:use-module (gnu packages tls)
#:use-module (gnu packages)
@@ -1069,7 +1070,7 @@ following features:
(define-public subversion
(package
(name "subversion")
- (version "1.8.19")
+ (version "1.10.0")
(source (origin
(method url-fetch)
(uri
@@ -1080,7 +1081,7 @@ following features:
"subversion-" version ".tar.bz2")))
(sha256
(base32
- "1gp6426gkdza6ni2whgifjcmjb4nq34ljy07yxkrhlarvfq6ks2n"))))
+ "115mlvmf663w16mc3xyypnaizq401vbypc56hl2ylzc3pcx3zwic"))))
(build-system gnu-build-system)
(arguments
'(#:phases
@@ -1096,6 +1097,11 @@ following features:
(substitute* "libtool"
(("\\\\`ls") (string-append "\\`" coreutils "/bin/ls")))
#t)))
+ (add-before 'build 'patch-test-sh
+ (lambda _
+ (substitute* "subversion/tests/libsvn_repos/repos-test.c"
+ (("#!/bin/sh") (string-append "#!" (which "sh"))))
+ #t))
(add-after 'install 'install-perl-bindings
(lambda* (#:key outputs #:allow-other-keys)
;; Follow the instructions from 'subversion/bindings/swig/INSTALL'.
@@ -1124,10 +1130,12 @@ following features:
(inputs
`(("apr" ,apr)
("apr-util" ,apr-util)
+ ("lz4" ,lz4)
("serf" ,serf)
("perl" ,perl)
- ("python" ,python-2) ; incompatible with Python 3 (print syntax)
+ ("python" ,python-wrapper)
("sqlite" ,sqlite)
+ ("utf8proc" ,utf8proc)
("zlib" ,zlib)))
(home-page "https://subversion.apache.org/")
(synopsis "Revision control system")