summaryrefslogtreecommitdiff
path: root/gnu/packages/version-control.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-04-03 12:21:29 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-04-03 12:21:29 +0200
commit5c151862c264257393139739178386182089b453 (patch)
tree8e106a3cf82a4fe714c4279aeceb0fe4850629e0 /gnu/packages/version-control.scm
parentfc8c229f14d541ae0fcf271a02c8d132cc84cb29 (diff)
downloadguix-patches-5c151862c264257393139739178386182089b453.tar
guix-patches-5c151862c264257393139739178386182089b453.tar.gz
gnu: git: Update to 2.17.0.
* gnu/packages/version-control.scm (git): Update to 2.17.0. [arguments]: Remove obsolete substitution.
Diffstat (limited to 'gnu/packages/version-control.scm')
-rw-r--r--gnu/packages/version-control.scm9
1 files changed, 3 insertions, 6 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 15fdfeca4b..1c87f2ea32 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -139,14 +139,14 @@ as well as the classic centralized workflow.")
(name "git")
;; XXX When updating Git, check if the special 'git:src' input to cgit needs
;; to be updated as well.
- (version "2.16.3")
+ (version "2.17.0")
(source (origin
(method url-fetch)
(uri (string-append "mirror://kernel.org/software/scm/git/git-"
version ".tar.xz"))
(sha256
(base32
- "0j1dwvg5llnj3g0fp8hdgpms4hp90qw9f6509vqw30dhwplrjpfn"))))
+ "1ismz7nsz8dgjmk782xr9s0mr2qh06f72pdcgbxfmnw1bvlya5p9"))))
(build-system gnu-build-system)
(native-inputs
`(("native-perl" ,perl)
@@ -159,7 +159,7 @@ as well as the classic centralized workflow.")
version ".tar.xz"))
(sha256
(base32
- "15ckcia3bdbn1dpwlh3fifd8fzk38l1pdgxsf2yl8l8xd1z8jqaz"))))))
+ "09rpjj0m97h5lpzpwk47m6xsz9gb8wqf1s3dfqma3mwav2pb3njb"))))))
(inputs
`(("curl" ,curl)
("expat" ,expat)
@@ -215,9 +215,6 @@ as well as the classic centralized workflow.")
(("/bin/sh") (which "sh"))
(("/usr/bin/perl") (which "perl"))
(("/usr/bin/python") (which "python")))
- (substitute* "perl/Makefile"
- ;; Don't create timestamped 'perllocal.pod'.
- (("\\$< PREFIX=") "$< NO_PERLLOCAL=1 PREFIX="))
#t))
(add-after 'configure 'add-PM.stamp
(lambda _