summaryrefslogtreecommitdiff
path: root/gnu/packages/version-control.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-04-30 16:03:39 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-04-30 21:36:10 +0200
commit443c432e90691f0a81bca6feb70322dc92706627 (patch)
tree954c96f4e9d7bdb5e1f36023d3aaf6d0ec65aca5 /gnu/packages/version-control.scm
parent53bed20918db76e021d39d6b82ac95a095893298 (diff)
downloadguix-patches-443c432e90691f0a81bca6feb70322dc92706627.tar
guix-patches-443c432e90691f0a81bca6feb70322dc92706627.tar.gz
gnu: reposurgeon: End all phases in truth.
* gnu/packages/version-control.scm (reposurgeon)[arguments]: Return #t from the ‘install-emacs-data’ phase, instead of COPY-FILE's undefined result.
Diffstat (limited to 'gnu/packages/version-control.scm')
-rw-r--r--gnu/packages/version-control.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index b82abaf9ed..848660bdd7 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -1468,7 +1468,8 @@ any project with more than one developer, is one of Aegis's major functions.")
(lambda* (#:key outputs #:allow-other-keys)
(install-file "reposurgeon-mode.el"
(string-append (assoc-ref outputs "out")
- "/share/emacs/site-lisp")))))))
+ "/share/emacs/site-lisp"))
+ #t)))))
(inputs
`(("python" ,python-wrapper)
("tzdata" ,tzdata)))