summaryrefslogtreecommitdiff
path: root/gnu/packages/tryton.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2021-08-27 15:09:30 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-09-21 21:00:30 +0200
commita7ce1ce19c1ec9734bd47dbccf87d5ffc8a8966d (patch)
treea86a3425237f55358c4f1293ec8261a028a7c170 /gnu/packages/tryton.scm
parentac9c7d89d868f76da555538696f2e563463cebc6 (diff)
downloadguix-patches-a7ce1ce19c1ec9734bd47dbccf87d5ffc8a8966d.tar
guix-patches-a7ce1ce19c1ec9734bd47dbccf87d5ffc8a8966d.tar.gz
gnu: Add trytond-production-work.
* gnu/packages/tryton.scm (trytond-production-work): New variable.
Diffstat (limited to 'gnu/packages/tryton.scm')
-rw-r--r--gnu/packages/tryton.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 9d497776e7..346d354b38 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -2499,6 +2499,33 @@ of times. On occasion there can be a production with the remaining
quantity.")
(license license:gpl3+)))
+(define-public trytond-production-work
+ (package
+ (name "trytond-production-work")
+ (version "6.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "trytond_production_work" version))
+ (sha256
+ (base32 "01a09snawlr224s5aqhrdkal14qry4hlfsglnsk09yzbw6fx196b"))))
+ (build-system python-build-system)
+ (arguments (tryton-arguments "production_work"))
+ (native-inputs `(,@%standard-trytond-native-inputs))
+ (propagated-inputs
+ `(("trytond" ,trytond)
+ ("trytond-company" ,trytond-company)
+ ("trytond-product" ,trytond-product)
+ ("trytond-production" ,trytond-production)
+ ("trytond-production-routing" ,trytond-production-routing)
+ ("trytond-stock" ,trytond-stock)))
+ (home-page "https://docs.tryton.org/projects/modules-production-work")
+ (synopsis "Tryton module for production work")
+ (description "The @emph{Production Work} Tryton module allows to manage
+work order for each production. It also adds in the production cost for the
+work cost.")
+ (license license:gpl3+)))
+
(define-public trytond-purchase
(package
(name "trytond-purchase")