summaryrefslogtreecommitdiff
path: root/gnu/packages/tryton.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2021-08-27 15:09:34 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-09-21 21:00:31 +0200
commit55d1a0ab508988ae98f15c58672dcd25aae42c0d (patch)
tree3caff8dbf0d9c0a441d22f6d1468dbe63f05bfa1 /gnu/packages/tryton.scm
parent42209cf3fe52ae52cfc38bff54874f86edaa2e69 (diff)
downloadguix-patches-55d1a0ab508988ae98f15c58672dcd25aae42c0d.tar
guix-patches-55d1a0ab508988ae98f15c58672dcd25aae42c0d.tar.gz
gnu: Add trytond-purchase-invoice-line-standalone.
* gnu/packages/tryton.scm (trytond-purchase-invoice-line-standalone): New variable.
Diffstat (limited to 'gnu/packages/tryton.scm')
-rw-r--r--gnu/packages/tryton.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 4fef20061a..935cc102cf 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -2761,6 +2761,31 @@ historization of the purchase and adds a revision counter which increases each
time the purchase is reset to draft.")
(license license:gpl3+)))
+(define-public trytond-purchase-invoice-line-standalone
+ (package
+ (name "trytond-purchase-invoice-line-standalone")
+ (version "6.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "trytond_purchase_invoice_line_standalone" version))
+ (sha256
+ (base32 "1qwa8a1vxalvb6r3d1w5wwpa9kx7w8c879x1zb4wwc9nqpdji8v0"))))
+ (build-system python-build-system)
+ (arguments (tryton-arguments "purchase_invoice_line_standalone"))
+ (native-inputs `(,@%standard-trytond-native-inputs))
+ (propagated-inputs
+ `(("trytond" ,trytond)
+ ("trytond-account-invoice-line-standalone"
+ ,trytond-account-invoice-line-standalone)
+ ("trytond-purchase" ,trytond-purchase)))
+ (home-page
+ "https://docs.tryton.org/projects/modules-purchase-invoice-line-standalone")
+ (synopsis "Tryton module for standalone invoice line from purchase")
+ (description "The @emph{Purchase Invoice Line Standalone} Tryton module
+makes purchase to generate invoice lines instead of invoices.")
+ (license license:gpl3+)))
+
(define-public trytond-purchase-request
(package
(name "trytond-purchase-request")