summaryrefslogtreecommitdiff
path: root/gnu/packages/tryton.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2021-08-27 15:09:21 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-09-21 21:00:28 +0200
commit17677a81e68b77c2abfba5eba3d81c5d96b0ed74 (patch)
tree807152f88e4d0e3b5f5e4622bb4ff71cfda77546 /gnu/packages/tryton.scm
parent2e192f7bbcda4526964f78c082306b54e1695ea2 (diff)
downloadguix-patches-17677a81e68b77c2abfba5eba3d81c5d96b0ed74.tar
guix-patches-17677a81e68b77c2abfba5eba3d81c5d96b0ed74.tar.gz
gnu: Add trytond-ldap-authentication.
* gnu/packages/tryton.scm (trytond-ldap-authentication): New variable.
Diffstat (limited to 'gnu/packages/tryton.scm')
-rw-r--r--gnu/packages/tryton.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 1bc1b9fb2c..4a69384e14 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -1879,6 +1879,28 @@ Incoterms on sales, purchases and shipments. The module contains the Incoterm
versions of 2010 and 2020.")
(license license:gpl3+)))
+(define-public trytond-ldap-authentication
+ (package
+ (name "trytond-ldap-authentication")
+ (version "6.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "trytond_ldap_authentication" version))
+ (sha256
+ (base32 "1iylbpp66qjff1mkp0w3a703pracpcv3bv25i2bafkmcjiv9b4jl"))))
+ (build-system python-build-system)
+ (arguments (tryton-arguments "ldap_authentication"))
+ (native-inputs `(,@%standard-trytond-native-inputs))
+ (propagated-inputs
+ `(("python-ldap3" ,python-ldap3)
+ ("trytond" ,trytond)))
+ (home-page "https://docs.tryton.org/projects/modules-ldap-authentication")
+ (synopsis "Tryton module to authenticate users through LDAP")
+ (description "The @emph{LDAP Authentication} Tryton module allows to
+authenticate users via a LDAP server.")
+ (license license:gpl3+)))
+
(define-public trytond-party
(package
(name "trytond-party")