summaryrefslogtreecommitdiff
path: root/gnu/packages/tryton.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2021-08-27 15:09:28 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-09-21 21:00:30 +0200
commit5f57c127012aa8db2285e4ba99c58e07463e4fe3 (patch)
treeba19426ffa58778136dbe053c00a5da09d648eae /gnu/packages/tryton.scm
parentde5a968ae5a7f9b54f27bcd465ab2be850a691ec (diff)
downloadguix-patches-5f57c127012aa8db2285e4ba99c58e07463e4fe3.tar
guix-patches-5f57c127012aa8db2285e4ba99c58e07463e4fe3.tar.gz
gnu: Add trytond-product-price-list-dates.
* gnu/packages/tryton.scm (trytond-product-price-list-dates): New variable.
Diffstat (limited to 'gnu/packages/tryton.scm')
-rw-r--r--gnu/packages/tryton.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 666455d29c..2fe2d0a115 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -2349,6 +2349,31 @@ following measurements to Product:")
to compute prices per product or category.")
(license license:gpl3+)))
+(define-public trytond-product-price-list-dates
+ (package
+ (name "trytond-product-price-list-dates")
+ (version "6.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "trytond_product_price_list_dates" version))
+ (sha256
+ (base32 "0p1n4qivj9gfhdy0357n53wswyi14rnanc2bkayiv3zfr7qkf2m1"))))
+ (build-system python-build-system)
+ (arguments (tryton-arguments "product_price_list_dates"))
+ (native-inputs
+ `(,@%standard-trytond-native-inputs
+ ("trytond-sale-price-list" ,trytond-sale-price-list)))
+ (propagated-inputs
+ `(("trytond" ,trytond)
+ ("trytond-product-price-list" ,trytond-product-price-list)))
+ (home-page
+ "https://docs.tryton.org/projects/modules-product-price-list-dates")
+ (synopsis "Tryton module to add dates on price list")
+ (description "The @emph{Product Price List Dates} Tryton module adds start
+date and end date conditions to the price list lines.")
+ (license license:gpl3+)))
+
(define-public trytond-purchase
(package
(name "trytond-purchase")