summaryrefslogtreecommitdiff
path: root/gnu/packages/tryton.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2021-08-27 15:09:28 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-09-21 21:00:30 +0200
commita53c6040e4cf15f161a010d39d72d05ed341df9d (patch)
tree8564392b16a4e93ea1fbe91b18bbf4ce8c82e720 /gnu/packages/tryton.scm
parentb5db20a05b820608509c4a125e4ea6b885a5ebe9 (diff)
downloadguix-patches-a53c6040e4cf15f161a010d39d72d05ed341df9d.tar
guix-patches-a53c6040e4cf15f161a010d39d72d05ed341df9d.tar.gz
gnu: Add trytond-production.
* gnu/packages/tryton.scm (trytond-production): New variable.
Diffstat (limited to 'gnu/packages/tryton.scm')
-rw-r--r--gnu/packages/tryton.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 43fa374704..382f814ed1 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -2398,6 +2398,30 @@ parent to the price list and the keyword `parent_unit_price` for the formula
which contains the unit price computed by the parent price list.")
(license license:gpl3+)))
+(define-public trytond-production
+ (package
+ (name "trytond-production")
+ (version "6.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "trytond_production" version))
+ (sha256
+ (base32 "0ys1wg52bs3i7yjrrkm9ycn07xz7fsb2pqc4a2bj44691pvrclpk"))))
+ (build-system python-build-system)
+ (arguments (tryton-arguments "production"))
+ (native-inputs `(,@%standard-trytond-native-inputs))
+ (propagated-inputs
+ `(("trytond" ,trytond)
+ ("trytond-company" ,trytond-company)
+ ("trytond-product" ,trytond-product)
+ ("trytond-stock" ,trytond-stock)))
+ (home-page "https://docs.tryton.org/projects/modules-production")
+ (synopsis "Tryton module for production")
+ (description "The @emph{Production} Tryton module defines basics
+for production management: Bill of material and production order.")
+ (license license:gpl3+)))
+
(define-public trytond-purchase
(package
(name "trytond-purchase")