summaryrefslogtreecommitdiff
path: root/gnu/packages/tryton.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2021-08-27 15:09:22 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-09-21 21:00:29 +0200
commita3ab0aa4da06ffd2ee8b054d4d881c46ed80406c (patch)
treefc5603a115a748cd5de5542c3452e4ff8df65ad0 /gnu/packages/tryton.scm
parent8688cc9442377ad743bc50d77943f0cd19d3c076 (diff)
downloadguix-patches-a3ab0aa4da06ffd2ee8b054d4d881c46ed80406c.tar
guix-patches-a3ab0aa4da06ffd2ee8b054d4d881c46ed80406c.tar.gz
gnu: Add trytond-marketing-email.
* gnu/packages/tryton.scm (trytond-marketing-email): New variable.
Diffstat (limited to 'gnu/packages/tryton.scm')
-rw-r--r--gnu/packages/tryton.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index a8c562f808..556a32e1f0 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -1949,6 +1949,31 @@ marketing actions to be automated. It is based on scenarios and activities
that are executed on selected records.")
(license license:gpl3+)))
+(define-public trytond-marketing-email
+ (package
+ (name "trytond-marketing-email")
+ (version "6.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "trytond_marketing_email" version))
+ (sha256
+ (base32 "07zh1pni4kpm6bsgyizz0a5k64nyxc9laxxaih9py7d24p9pgvky"))))
+ (build-system python-build-system)
+ (arguments (tryton-arguments "marketing_email"))
+ (native-inputs `(,@%standard-trytond-native-inputs))
+ (propagated-inputs
+ `(("trytond" ,trytond)
+ ("trytond-marketing" ,trytond-marketing)
+ ("trytond-party" ,trytond-party)
+ ("trytond-web-shortener" ,trytond-web-shortener)
+ ("trytond-web-user" ,trytond-web-user)))
+ (home-page "https://docs.tryton.org/projects/modules-marketing-email")
+ (synopsis "Tryton module to manage marketing mailing lists")
+ (description "This package provides a Tryton module for managing marketing
+mailing lists.")
+ (license license:gpl3+)))
+
(define-public trytond-party
(package
(name "trytond-party")