summaryrefslogtreecommitdiff
path: root/gnu/packages/tryton.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2021-08-27 15:09:45 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-09-21 21:00:33 +0200
commit77a3fb1d768b676cf390f80ee7a50a0e1a2e858e (patch)
tree9e3b0096f83edce2189f28fdb9e7e78294e434f2 /gnu/packages/tryton.scm
parentc7797fd49ea5c6c69bcc8547922b112d4cf488cc (diff)
downloadguix-patches-77a3fb1d768b676cf390f80ee7a50a0e1a2e858e.tar
guix-patches-77a3fb1d768b676cf390f80ee7a50a0e1a2e858e.tar.gz
gnu: Add trytond-sale-subscription.
* gnu/packages/tryton.scm (trytond-sale-subscription): New variable.
Diffstat (limited to 'gnu/packages/tryton.scm')
-rw-r--r--gnu/packages/tryton.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index e03f86f25a..0dd0a6463d 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -3534,6 +3534,33 @@ supply) is lower than the quantity sold by considering other sales and the
stock forecasts.")
(license license:gpl3+)))
+(define-public trytond-sale-subscription
+ (package
+ (name "trytond-sale-subscription")
+ (version "6.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "trytond_sale_subscription" version))
+ (sha256
+ (base32 "092ljl0ywybwchp4qfki752nclqc6hkx2h99cd1h3g998jv3l72x"))))
+ (build-system python-build-system)
+ (arguments (tryton-arguments "sale_subscription"))
+ (native-inputs `(,@%standard-trytond-native-inputs))
+ (propagated-inputs
+ `(("trytond" ,trytond)
+ ("trytond-account" ,trytond-account)
+ ("trytond-account-invoice" ,trytond-account-invoice)
+ ("trytond-company" ,trytond-company)
+ ("trytond-currency" ,trytond-currency)
+ ("trytond-product" ,trytond-product)
+ ("trytond-sale" ,trytond-sale)))
+ (home-page "https://docs.tryton.org/projects/modules-sale-subscription")
+ (synopsis "Tryton module for subscription")
+ (description "The @emph{Sale Subscription} module defines subscription,
+services and recurrence rule models.")
+ (license license:gpl3+)))
+
(define-public trytond-stock
(package
(name "trytond-stock")