summaryrefslogtreecommitdiff
path: root/gnu/packages/tryton.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2021-08-27 15:09:24 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-09-21 21:00:29 +0200
commita7a084fbffee4fb64111726c5b299495a9760d79 (patch)
tree57c211ff46cb75d79fcc800140c2ba518959ab43 /gnu/packages/tryton.scm
parent43304c20176b8372a6f16ef5736453acd1cb74de (diff)
downloadguix-patches-a7a084fbffee4fb64111726c5b299495a9760d79.tar
guix-patches-a7a084fbffee4fb64111726c5b299495a9760d79.tar.gz
gnu: Add trytond-product-classification.
* gnu/packages/tryton.scm (trytond-product-classification): New variable.
Diffstat (limited to 'gnu/packages/tryton.scm')
-rw-r--r--gnu/packages/tryton.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 7d8d015077..dd8b6d51fc 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -2147,6 +2147,30 @@ Template and Product.")
models `Attribute` and `Attribute Set` for products.")
(license license:gpl3+)))
+(define-public trytond-product-classification
+ (package
+ (name "trytond-product-classification")
+ (version "6.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "trytond_product_classification" version))
+ (sha256
+ (base32 "1sq42siqq8w6dd8jnqnkzy3npaf9g2nrdzazkl6nw5dysvpsz8cr"))))
+ (build-system python-build-system)
+ (arguments (tryton-arguments "product_classification"))
+ (native-inputs `(,@%standard-trytond-native-inputs))
+ (propagated-inputs
+ `(("trytond" ,trytond)
+ ("trytond-product" ,trytond-product)))
+ (home-page
+ "https://docs.tryton.org/projects/modules-product-classification")
+ (synopsis "Tryton module to implement product classification")
+ (description "The @emph{Product Classification} Tryton module defines the
+tools for other modules to create classifications of products. It adds a
+reference field classification to the product template.")
+ (license license:gpl3+)))
+
(define-public trytond-purchase
(package
(name "trytond-purchase")