summaryrefslogtreecommitdiff
path: root/gnu/packages/tryton.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2021-08-27 15:09:20 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-09-21 21:00:28 +0200
commit429dc783c1bd2d8e8f1051352bfd26e7ca5d2bd0 (patch)
treedc014bda4e383613d0b86322d688edb701a09aee /gnu/packages/tryton.scm
parent8dd9ba3947b302392dfa47f20f45f64043993591 (diff)
downloadguix-patches-429dc783c1bd2d8e8f1051352bfd26e7ca5d2bd0.tar
guix-patches-429dc783c1bd2d8e8f1051352bfd26e7ca5d2bd0.tar.gz
gnu: Add trytond-edocument-unece.
* gnu/packages/tryton.scm (trytond-edocument-unece): New variable.
Diffstat (limited to 'gnu/packages/tryton.scm')
-rw-r--r--gnu/packages/tryton.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index ed58ffb233..3e8354e2d3 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -1812,6 +1812,36 @@ electronic document from UN/CEFACT. Supported formats are:
@end itemize")
(license license:gpl3+)))
+(define-public trytond-edocument-unece
+ (package
+ (name "trytond-edocument-unece")
+ (version "6.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "trytond_edocument_unece" version))
+ (sha256
+ (base32 "1ri3gjvk0h0sljbgh7h2j0rbr3953p3k21l8x6rhrnh1q2rqgi70"))))
+ (build-system python-build-system)
+ (arguments (tryton-arguments "edocument_unece"))
+ (native-inputs `(,@%standard-trytond-native-inputs))
+ (propagated-inputs
+ `(("trytond" ,trytond)
+ ("trytond-account" ,trytond-account)
+ ("trytond-product" ,trytond-product)))
+ (home-page "https://docs.tryton.org/projects/modules-edocument-unece")
+ (synopsis "Tryton module for electronic document UNECE codes")
+ (description "The @emph{Edocument UNECE} Tryton module adds several codes
+from the UNECE. Supported formats are:
+
+@itemize
+@item Recommendation N°. 20 Codes for
+ Units of Measure Used in International Trade
+@item 5153 Duty or tax or fee type name code
+@item 5305 Duty or tax or fee category code
+@end itemize")
+ (license license:gpl3+)))
+
(define-public trytond-party
(package
(name "trytond-party")