summaryrefslogtreecommitdiff
path: root/gnu/packages/tryton.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2021-08-27 15:09:19 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-09-21 21:00:28 +0200
commit35869e854c402c54df76f141b2d5adebea7420c2 (patch)
tree7808b8acef655a8adeec63df3c275497d2523ad7 /gnu/packages/tryton.scm
parenta22db49e5e87d7731ceba012988715f20eeb9640 (diff)
downloadguix-patches-35869e854c402c54df76f141b2d5adebea7420c2.tar
guix-patches-35869e854c402c54df76f141b2d5adebea7420c2.tar.gz
gnu: Add trytond-customs.
* gnu/packages/tryton.scm (trytond-customs): New variable.
Diffstat (limited to 'gnu/packages/tryton.scm')
-rw-r--r--gnu/packages/tryton.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 3f8920b30f..4f7bd60d12 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -1737,6 +1737,31 @@ currency and rate.")
(define-public python-trytond-currency
(deprecated-package "python-trytond-currency" trytond-currency))
+(define-public trytond-customs
+ (package
+ (name "trytond-customs")
+ (version "6.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "trytond_customs" version))
+ (sha256
+ (base32 "1qilj1b9zr35z15313xbvgklf87dgxddvkcnymklwp9n7vs7hrz5"))))
+ (build-system python-build-system)
+ (arguments (tryton-arguments "customs"))
+ (native-inputs `(,@%standard-trytond-native-inputs))
+ (propagated-inputs
+ `(("python-simpleeval" ,python-simpleeval)
+ ("trytond" ,trytond)
+ ("trytond-country" ,trytond-country)
+ ("trytond-currency" ,trytond-currency)
+ ("trytond-product" ,trytond-product)))
+ (home-page "https://docs.tryton.org/projects/modules-customs")
+ (synopsis "Tryton module for customs")
+ (description "The @emph{Customs} Tryton module allows to define customs
+duty based on the tariff code.")
+ (license license:gpl3+)))
+
(define-public trytond-party
(package
(name "trytond-party")