summaryrefslogtreecommitdiff
path: root/gnu/packages/tryton.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2021-08-27 15:09:58 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-09-21 21:00:35 +0200
commit3044c97b6465b798acbd28a75884ccc8341c0670 (patch)
treeb6f9ec2fed30cc5a32f776b66e0c6149ddc5fac2 /gnu/packages/tryton.scm
parent5b287fa6f741b21122536dbaf53222c83704ac3a (diff)
downloadguix-patches-3044c97b6465b798acbd28a75884ccc8341c0670.tar
guix-patches-3044c97b6465b798acbd28a75884ccc8341c0670.tar.gz
gnu: Add trytond-user-role.
* gnu/packages/tryton.scm (trytond-user-role): New variable.
Diffstat (limited to 'gnu/packages/tryton.scm')
-rw-r--r--gnu/packages/tryton.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index c5c2d6d2fe..5b6cfa0e27 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -4355,3 +4355,26 @@ periods.")
(description "The @emph{Timesheet Cost} Tryton module adds cost price per
employee.")
(license license:gpl3+)))
+
+(define-public trytond-user-role
+ (package
+ (name "trytond-user-role")
+ (version "6.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "trytond_user_role" version))
+ (sha256
+ (base32 "11sjz46kagrpig5n05pp52yph4z0l1zm140q9wsagjcmzkx7s6gf"))))
+ (build-system python-build-system)
+ (arguments (tryton-arguments "user_role"))
+ (native-inputs `(,@%standard-trytond-native-inputs))
+ (propagated-inputs
+ `(("trytond" ,trytond)))
+ (home-page "https://docs.tryton.org/projects/modules-user-role")
+ (synopsis "Tryton module to manage roles on users")
+ (description "This package provides a Tryton module for assigning roles to
+user instead of groups. A Role is defined by a set of groups. When a role is
+added to a user, it overrides the existing groups. A role can be added to a
+user for a period of time only.")
+ (license license:gpl3+)))