summaryrefslogtreecommitdiff
path: root/gnu/packages/toys.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2022-06-12 22:49:47 +0200
committerLudovic Courtès <ludo@gnu.org>2022-06-12 22:49:47 +0200
commit622545de6c413675b00212336d633c4c6ee3d2bc (patch)
tree1e35bd4b023fcc5958b0c4e65b8b69024b1a0c2d /gnu/packages/toys.scm
parent091eb323ba2787ce64a1fb2796e7e06dbee6037c (diff)
parent9c036f2dfb8f25b7eb40bc6946845183e0a54d2e (diff)
downloadguix-patches-622545de6c413675b00212336d633c4c6ee3d2bc.tar
guix-patches-622545de6c413675b00212336d633c4c6ee3d2bc.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/toys.scm')
-rw-r--r--gnu/packages/toys.scm18
1 files changed, 9 insertions, 9 deletions
diff --git a/gnu/packages/toys.scm b/gnu/packages/toys.scm
index 09426fe6fa..4fa6966ca9 100644
--- a/gnu/packages/toys.scm
+++ b/gnu/packages/toys.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2017, 2018, 2020, 2021 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2017, 2018, 2020–2022 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2019 Jesse Gibbons <jgibbons2357+guix@gmail.com>
;;; Copyright © 2019, 2020, 2021 Timotej Lazar <timotej.lazar@araneo.si>
;;; Copyright © 2020 Efraim Flashner <efraim@flashner.co.il>
@@ -57,8 +57,7 @@
(for-each delete-file-recursively
(cons* "bitmaps/bsd" "bitmaps/sakura" "bitmaps/tomoyo"
"bitmasks/bsd" "bitmasks/sakura" "bitmasks/tomoyo"
- (find-files "cursors" "(bsd|card|petal).*\\.xbm")))
- #t))))
+ (find-files "cursors" "(bsd|card|petal).*\\.xbm")))))))
(build-system gnu-build-system)
(native-inputs
(list imake))
@@ -73,8 +72,7 @@
(invoke "xmkmf")
;; Fix incorrectly generated compiler flags.
(substitute* "Makefile"
- (("(CDEBUGFLAGS = ).*" _ front) (string-append front "-O2\n")))
- #t))
+ (("(CDEBUGFLAGS = ).*" _ front) (string-append front "-O2\n")))))
(replace 'install
(lambda* (#:key outputs make-flags #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
@@ -89,12 +87,14 @@
(copy-file "oneko.man" (string-append man6 "/oneko.6"))
(copy-file "oneko.man.jp" (string-append man6-ja "/oneko.6"))
(for-each (lambda (file) (install-file file doc))
- (find-files "." "README.*")))
- #t)))))
+ (find-files "." "README.*"))))))))
(home-page "http://www.daidouji.com/oneko/")
(synopsis "Cute cat chasing your mouse pointer")
- (description "Displays a cat or another animated character that chases the
-mouse pointer around the screen while you work.")
+ (description
+ "Oneko displays an animated cat or dog that chases the mouse pointer---now
+an actual mouse or a bone---around the screen while you work.
+
+It was written for the X Window system and does not work well on Wayland.")
(license license:public-domain))) ; see https://directory.fsf.org/wiki/Oneko
(define-public sl