summaryrefslogtreecommitdiff
path: root/gnu/packages/tor.scm
diff options
context:
space:
mode:
authorfanquake <fanquake@gmail.com>2023-08-24 09:47:33 +0100
committerLudovic Courtès <ludo@gnu.org>2023-09-14 16:39:20 +0200
commitde64e412f3684d54bd2a485920cd3287a551f793 (patch)
treedf687d03ecdfc1cf3fdf3cef6a5d215d8226c138 /gnu/packages/tor.scm
parent08e8c3483fa16b4fc9b1fbd92f52bbc778f65249 (diff)
downloadguix-patches-de64e412f3684d54bd2a485920cd3287a551f793.tar
guix-patches-de64e412f3684d54bd2a485920cd3287a551f793.tar.gz
gnu: tor: Update to 0.4.8.5.
* gnu/packages/tor.scm (tor): Update to 0.4.8.5. * gnu/packages/tor.scm (tor)[arguments]<#:configure-flags>: Add "--enable-gpl". * gnu/packages/patches/tor-remove-defensive-assert.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. * gnu/packages/tor.scm (tor)[source]: Add patch to remove defensive assert. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/tor.scm')
-rw-r--r--gnu/packages/tor.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/tor.scm b/gnu/packages/tor.scm
index 7fec88656f..44e62b63cc 100644
--- a/gnu/packages/tor.scm
+++ b/gnu/packages/tor.scm
@@ -63,18 +63,20 @@
(define-public tor
(package
(name "tor")
- (version "0.4.7.14")
+ (version "0.4.8.5")
(source (origin
(method url-fetch)
(uri (string-append "https://dist.torproject.org/tor-"
version ".tar.gz"))
(sha256
(base32
- "1y2xwrji1rvk6h0k15705yra5s74h72h2g84x02zr0338vv6gb55"))))
+ "06g1awb4piqvgxa97pyswxgjzkpj8rx3iy2jbiaygvi99b8wymv9"))
+ (patches (search-patches "tor-remove-defensive-assert.patch"))))
(build-system gnu-build-system)
(arguments
(list #:configure-flags
- #~(list "--enable-lzma"
+ #~(list "--enable-gpl"
+ "--enable-lzma"
"--enable-zstd")
#:phases
#~(modify-phases %standard-phases