summaryrefslogtreecommitdiff
path: root/gnu/packages/toolkits.scm
diff options
context:
space:
mode:
authorJohn Kehayias <john.kehayias@protonmail.com>2023-06-27 20:49:34 -0400
committerJohn Kehayias <john.kehayias@protonmail.com>2023-06-29 10:51:57 -0400
commit2b25bc03a11e1c6a473bbb000c35e94233120346 (patch)
tree04759910a47caf8c64c42f4501812402e5d4bb5e /gnu/packages/toolkits.scm
parent15056f47c217d87bf0914735fb52833a5457dc37 (diff)
downloadguix-patches-2b25bc03a11e1c6a473bbb000c35e94233120346.tar
guix-patches-2b25bc03a11e1c6a473bbb000c35e94233120346.tar.gz
gnu: imgui-1.86: Adjust make-flags.
* gnu/packages/toolkits.scm (imgui-1.86)[arguments]: Remove the "-DImDrawIdx=unsigned int" make-flag which breaks the display of mangohud, the only dependent.
Diffstat (limited to 'gnu/packages/toolkits.scm')
-rw-r--r--gnu/packages/toolkits.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/toolkits.scm b/gnu/packages/toolkits.scm
index 1af10d83f4..46b7fd2cd6 100644
--- a/gnu/packages/toolkits.scm
+++ b/gnu/packages/toolkits.scm
@@ -168,4 +168,10 @@ standard operating system features.")
(file-name (git-file-name name version))
(sha256
(base32
- "02a7b05zrka20jhzag2jb4jl624i1m456bsv69jb9zgys2p9dv1n"))))))
+ "02a7b05zrka20jhzag2jb4jl624i1m456bsv69jb9zgys2p9dv1n"))))
+ (arguments
+ (substitute-keyword-arguments (package-arguments imgui)
+ ((#:make-flags flags ''())
+ ;; Remove the "-DImDrawIdx=unsigned int" make-flag as this breaks
+ ;; mangohud, the only user of this version.
+ #~(delete "-DImDrawIdx=unsigned int" #$flags))))))