summaryrefslogtreecommitdiff
path: root/gnu/packages/tls.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-09-09 15:31:23 +0200
committerLudovic Courtès <ludo@gnu.org>2015-09-09 15:31:23 +0200
commitb6cb13583b9aa9e6e7470ac8e873e00a8c5a2500 (patch)
tree6070358f78f2727f6ebc2710bcd7c0207b33f7f2 /gnu/packages/tls.scm
parent6f6eb857602393523071caf433a4f34c74b85531 (diff)
downloadguix-patches-b6cb13583b9aa9e6e7470ac8e873e00a8c5a2500.tar
guix-patches-b6cb13583b9aa9e6e7470ac8e873e00a8c5a2500.tar.gz
gnu: openssl: Use 'modify-phases'.
* gnu/packages/tls.scm (openssl)[arguments]: Use 'modify-phases'.
Diffstat (limited to 'gnu/packages/tls.scm')
-rw-r--r--gnu/packages/tls.scm53
1 files changed, 27 insertions, 26 deletions
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index c9c84dff2f..5bbe367286 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -203,32 +203,33 @@ required structures.")
#:parallel-tests? #f
#:test-target "test"
#:phases
- (alist-replace
- 'configure
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- (zero?
- (system* "./config"
- "shared" ; build shared libraries
- "--libdir=lib"
- (string-append "--prefix=" out)
- ;; XXX FIXME: Work around a code generation bug in GCC
- ;; 4.9.3 on ARM when compiled with -mfpu=neon. See:
- ;; <https://gcc.gnu.org/bugzilla/show_bug.cgi?id=66917>
- ,@(if (and (not (%current-target-system))
- (string-prefix? "armhf" (%current-system)))
- '("-mfpu=vfpv3")
- '())))))
- (alist-cons-before
- 'patch-source-shebangs 'patch-tests
- (lambda* (#:key inputs native-inputs #:allow-other-keys)
- (let ((bash (assoc-ref (or native-inputs inputs) "bash")))
- (substitute* (find-files "test" ".*")
- (("/bin/sh")
- (string-append bash "/bin/bash"))
- (("/bin/rm")
- "rm"))))
- %standard-phases))))
+ (modify-phases %standard-phases
+ (replace
+ 'configure
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (zero?
+ (system* "./config"
+ "shared" ;build shared libraries
+ "--libdir=lib"
+ (string-append "--prefix=" out)
+
+ ;; XXX FIXME: Work around a code generation bug in GCC
+ ;; 4.9.3 on ARM when compiled with -mfpu=neon. See:
+ ;; <https://gcc.gnu.org/bugzilla/show_bug.cgi?id=66917>
+ ,@(if (and (not (%current-target-system))
+ (string-prefix? "armhf" (%current-system)))
+ '("-mfpu=vfpv3")
+ '()))))))
+ (add-before
+ 'patch-source-shebangs 'patch-tests
+ (lambda* (#:key inputs native-inputs #:allow-other-keys)
+ (let ((bash (assoc-ref (or native-inputs inputs) "bash")))
+ (substitute* (find-files "test" ".*")
+ (("/bin/sh")
+ (string-append bash "/bin/bash"))
+ (("/bin/rm")
+ "rm"))))))))
(native-search-paths
;; FIXME: These two variables must designate a single file or directory
;; and are not actually "search paths." In practice it works OK in user