summaryrefslogtreecommitdiff
path: root/gnu/packages/tls.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-08-19 01:39:55 -0400
committerMark H Weaver <mhw@netris.org>2015-08-21 12:02:20 -0400
commit9cdce047d0b79f81e2888fc82fc2c8a61cb1aee4 (patch)
treebc59aa0e21e5badad36c671341147c1bbec30ed0 /gnu/packages/tls.scm
parent80601ec17991b632dc29478fc5f2d6e04f64df74 (diff)
downloadguix-patches-9cdce047d0b79f81e2888fc82fc2c8a61cb1aee4.tar
guix-patches-9cdce047d0b79f81e2888fc82fc2c8a61cb1aee4.tar.gz
gnu: gnutls: Update to 3.4.4.1.
* gnu/packages/patches/gnutls-doc-fix.patch: New file. * gnu-system.am (dist_patch_DATA): Add it. * gnu/packages/tls.scm (gnutls): Update to 3.4.4.1. Add patch. [arguments]: Add 'delete-prebuilt-unfixed-info-file' phase. In 'move-doc' phase, copy man pages to the correct directory. [native-inputs]: Add 'texinfo'.
Diffstat (limited to 'gnu/packages/tls.scm')
-rw-r--r--gnu/packages/tls.scm15
1 files changed, 12 insertions, 3 deletions
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index 5dd2adc1e6..c9c84dff2f 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -105,7 +105,7 @@ living in the same process.")
(define-public gnutls
(package
(name "gnutls")
- (version "3.4.1")
+ (version "3.4.4.1")
(source (origin
(method url-fetch)
(uri
@@ -116,7 +116,8 @@ living in the same process.")
"/gnutls-" version ".tar.xz"))
(sha256
(base32
- "0bmih0zyiplr4v8798w0v9g3215zmganq18n8935cizkxj5zbdg9"))))
+ "1xf354xafavqhi207ll1m1isd4l5b31lic2sz9lw0j0r0fcxfnsj"))
+ (patches (list (search-patch "gnutls-doc-fix.patch")))))
(build-system gnu-build-system)
(arguments
'(#:configure-flags
@@ -140,12 +141,19 @@ living in the same process.")
#:phases (modify-phases %standard-phases
(add-after
+ 'unpack 'delete-prebuilt-unfixed-info-file
+ (lambda _
+ ;; XXX Delete the prebuilt info file, so that it will be
+ ;; rebuilt with the fixes in gnutls-doc-fix.patch.
+ (delete-file "doc/gnutls.info")
+ #t))
+ (add-after
'install 'move-doc
(lambda* (#:key outputs #:allow-other-keys)
;; Copy the 4.1 MiB of section 3 man pages to "doc".
(let* ((out (assoc-ref outputs "out"))
(doc (assoc-ref outputs "doc"))
- (mandir (string-append doc "/share/man"))
+ (mandir (string-append doc "/share/man/man3"))
(oldman (string-append out "/share/man/man3")))
(mkdir-p mandir)
(copy-recursively oldman mandir)
@@ -156,6 +164,7 @@ living in the same process.")
"doc")) ;4.1 MiB of man pages
(native-inputs
`(("pkg-config" ,pkg-config)
+ ("texinfo" ,texinfo) ; XXX needed only to replace prebuilt, unfixed docs.
("which" ,which)))
(inputs
`(("guile" ,guile-2.0)