summaryrefslogtreecommitdiff
path: root/gnu/packages/tls.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-05-26 17:03:07 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-05-26 17:04:18 +0200
commitd5c472a21685b73947653cc3758d71109d7ee7b6 (patch)
treeed48b928f3e79038e0ecfa11570274065f2c571d /gnu/packages/tls.scm
parent26633cb8b305ea25a2cdeb14fd47842d5a9940f1 (diff)
downloadguix-patches-d5c472a21685b73947653cc3758d71109d7ee7b6.tar
guix-patches-d5c472a21685b73947653cc3758d71109d7ee7b6.tar.gz
gnu: p11-kit: Update to 0.23.11.
* gnu/packages/tls.scm (p11-kit): Update to 0.23.11. [arguments]: Add #:phases. Drop new "runtime" test.
Diffstat (limited to 'gnu/packages/tls.scm')
-rw-r--r--gnu/packages/tls.scm18
1 files changed, 14 insertions, 4 deletions
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index 45a36db5c2..5e17a15db6 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -9,7 +9,7 @@
;;; Copyright © 2016, 2017, 2018 Nils Gillmann <ng0@n0.is>
;;; Copyright © 2016 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
-;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2017, 2018 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2017 Rutger Helling <rhelling@mykolab.com>
;;;
@@ -125,7 +125,7 @@ in intelligent transportation networks.")
(define-public p11-kit
(package
(name "p11-kit")
- (version "0.23.10")
+ (version "0.23.11")
(source
(origin
(method url-fetch)
@@ -133,7 +133,7 @@ in intelligent transportation networks.")
"download/" version "/p11-kit-" version ".tar.gz"))
(sha256
(base32
- "0hxfwnyb5yllvlsh0cj6favcph36gm94b6df7zhl7xay48zjl8gr"))))
+ "0asaxbypvns5xf9hb5jy0kijz0b3hp1s8likhywmry3klpdchhxj"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)))
@@ -141,7 +141,17 @@ in intelligent transportation networks.")
`(("libffi" ,libffi)
("libtasn1" ,libtasn1)))
(arguments
- `(#:configure-flags '("--without-trust-paths")))
+ `(#:configure-flags '("--without-trust-paths")
+ #:phases (modify-phases %standard-phases
+ (add-before 'check 'prepare-tests
+ (lambda _
+ ;; "test-runtime" expects XDG_RUNTIME_DIR to be set up
+ ;; and looks for .cache and other directories (only).
+ ;; For simplicity just drop it since it is irrelevant
+ ;; in the build container.
+ (substitute* "Makefile"
+ (("test-runtime\\$\\(EXEEXT\\)") ""))
+ #t)))))
(home-page "https://p11-glue.freedesktop.org/p11-kit.html")
(synopsis "PKCS#11 library")
(description