summaryrefslogtreecommitdiff
path: root/gnu/packages/tls.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-10-04 17:26:57 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-10-04 18:34:29 +0200
commit8e87aa04979dae66a1e45b54c0f92da07745e1e6 (patch)
treec3fdd0aab0c5d3a0c154d6ad34d6ed17dbbcc968 /gnu/packages/tls.scm
parent38a9bf805d7ea476dce2a271bd93c36afb6ba3ae (diff)
downloadguix-patches-8e87aa04979dae66a1e45b54c0f92da07745e1e6.tar
guix-patches-8e87aa04979dae66a1e45b54c0f92da07745e1e6.tar.gz
gnu: hiawatha: Update to 10.8.3.
* gnu/packages/web.scm (hiawatha): Update to 10.8.3. [source]: Also delete bundled copy of nghttp2. [inputs]: Use mbedtls-for-hiawatha instead of vanilla mbedtls-apache. * gnu/packages/tls.scm (mbedtls-for-hiawatha): New public variable.
Diffstat (limited to 'gnu/packages/tls.scm')
-rw-r--r--gnu/packages/tls.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index f92a36b6e2..715148c432 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -869,6 +869,24 @@ coding footprint.")
(home-page "https://tls.mbed.org")
(license license:asl2.0)))
+;; The Hiawatha Web server requires some specific features to be enabled.
+(define-public mbedtls-for-hiawatha
+ (hidden-package
+ (package
+ (inherit mbedtls-apache)
+ (arguments
+ (substitute-keyword-arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'configure 'configure-extra-features
+ (lambda _
+ (for-each (lambda (feature)
+ (invoke "scripts/config.pl" "set" feature))
+ (list "MBEDTLS_THREADING_C"
+ "MBEDTLS_THREADING_PTHREAD"))
+ #t)))
+ ,@(package-arguments mbedtls-apache)))))))
+
(define-public ghc-tls
(package
(name "ghc-tls")