summaryrefslogtreecommitdiff
path: root/gnu/packages/tls.scm
diff options
context:
space:
mode:
authorGreg Hogan <code@greghogan.com>2021-03-18 17:28:07 +0000
committerLudovic Courtès <ludo@gnu.org>2021-10-16 00:01:57 +0200
commit02f849ad7a2cbaf2454628cca50de8987defb189 (patch)
tree541f5f94df09d2b9af23f6939aa95a5a0f9fae07 /gnu/packages/tls.scm
parent30ddb0be6514e3d48609b10b9581e6dd32d9cd40 (diff)
downloadguix-patches-02f849ad7a2cbaf2454628cca50de8987defb189.tar
guix-patches-02f849ad7a2cbaf2454628cca50de8987defb189.tar.gz
gnu: s2n: Update to 1.0.10-7f43b102.
* gnu/packages/tls.scm (s2n): Update to 1.0.10-7f43b102. [source, home-page]: Remove URL redirect. [arguments]: Enable testing. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/tls.scm')
-rw-r--r--gnu/packages/tls.scm56
1 files changed, 28 insertions, 28 deletions
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index 69ed9de11f..564e52086a 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -1141,39 +1141,39 @@ derived from Mozilla's collection.")
(license license:mpl2.0))))
(define-public s2n
- (package
- (name "s2n")
- (version "1.0.10")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url (string-append "https://github.com/awslabs/" name))
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0ampvh2n235hhd9nabgjjvja7d5r5kj45q56ass1k8g52a6xg0jq"))))
- (build-system cmake-build-system)
- (arguments
- '(#:tests? #f ; tests fail to build for static library
- #:configure-flags
- '("-DBUILD_TESTING=OFF"
- "-DBUILD_SHARED_LIBS=ON")))
- (propagated-inputs
- `(("openssl" ,openssl)
- ("openssl:static" ,openssl "static")))
- (synopsis "SSL/TLS implementation in C99")
- (description
- "This library provides a C99 implementation of SSL/TLS. It is designed to
-be familiar to users of the widely-used POSIX I/O APIs. It supports blocking,
-non-blocking, and full-duplex I/O. There are no locks or mutexes.
+ (let* ((commit "7f43b102def1d52422f6c3e48d5cb3e6dd26c646")
+ (revision "1"))
+ (package
+ (name "s2n")
+ (version (git-version "1.0.10" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/aws/s2n-tls")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "06rqg0vcispi63cmcza9j7ix80l0w6wmbw81qlg4fq8l1lg9nyvl"))))
+ (build-system cmake-build-system)
+ (arguments
+ '(#:configure-flags
+ '("-DBUILD_SHARED_LIBS=ON")))
+ (propagated-inputs
+ `(("openssl" ,openssl)
+ ("openssl:static" ,openssl "static")))
+ (synopsis "SSL/TLS implementation in C99")
+ (description
+ "This library provides a C99 implementation of SSL/TLS. It is designed
+to be familiar to users of the widely-used POSIX I/O APIs. It supports
+blocking, non-blocking, and full-duplex I/O. There are no locks or mutexes.
As it can be difficult to keep track of which encryption algorithms and
protocols are best to use, s2n-tls features a simple API to use the latest
default set of preferences. Remaining on a specific version for backwards
compatibility is also supported.")
- (home-page "https://github.com/awslabs/s2n")
- (license license:asl2.0)))
+ (home-page "https://github.com/aws/s2n-tls")
+ (license license:asl2.0))))
(define-public wolfssl
(package