summaryrefslogtreecommitdiff
path: root/gnu/packages/tls.scm
diff options
context:
space:
mode:
authorGreg Hogan <code@greghogan.com>2021-10-18 13:12:07 +0000
committerLudovic Courtès <ludo@gnu.org>2021-11-16 16:59:50 +0100
commitcf48bf8607ae1a1b8c4771c4db016614a00eb8db (patch)
treeb97f18dfd525e6a8de056e63dc0d4a98260727c4 /gnu/packages/tls.scm
parent206f2693fd219b8b61d268056e37d3961559cbaf (diff)
downloadguix-patches-cf48bf8607ae1a1b8c4771c4db016614a00eb8db.tar
guix-patches-cf48bf8607ae1a1b8c4771c4db016614a00eb8db.tar.gz
gnu: s2n: Update to 1.1.0.
* gnu/packages/tls.scm (s2n): Update to 1.1.0. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/tls.scm')
-rw-r--r--gnu/packages/tls.scm53
1 files changed, 26 insertions, 27 deletions
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index b0a0128140..905197525d 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -1157,39 +1157,38 @@ derived from Mozilla's collection.")
(license license:mpl2.0))))
(define-public s2n
- (let* ((commit "7f43b102def1d52422f6c3e48d5cb3e6dd26c646")
- (revision "1"))
- (package
- (name "s2n")
- (version (git-version "1.0.10" revision commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/aws/s2n-tls")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "06rqg0vcispi63cmcza9j7ix80l0w6wmbw81qlg4fq8l1lg9nyvl"))))
- (build-system cmake-build-system)
- (arguments
- '(#:configure-flags
- '("-DBUILD_SHARED_LIBS=ON")))
- (propagated-inputs
- `(("openssl" ,openssl)
- ("openssl:static" ,openssl "static")))
- (synopsis "SSL/TLS implementation in C99")
- (description
- "This library provides a C99 implementation of SSL/TLS. It is designed
-to be familiar to users of the widely-used POSIX I/O APIs. It supports
-blocking, non-blocking, and full-duplex I/O. There are no locks or mutexes.
+ (package
+ (name "s2n")
+ ; Update only when updating aws-crt-cpp.
+ (version "1.1.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/aws/s2n-tls")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "14dhdddlph36nshdkh0v33718hxjx5vxqxmkw7707393q0qrgipw"))))
+ (build-system cmake-build-system)
+ (arguments
+ '(#:configure-flags
+ '("-DBUILD_SHARED_LIBS=ON")))
+ (propagated-inputs
+ `(("openssl" ,openssl)
+ ("openssl:static" ,openssl "static")))
+ (synopsis "SSL/TLS implementation in C99")
+ (description
+ "This library provides a C99 implementation of SSL/TLS. It is designed to
+be familiar to users of the widely-used POSIX I/O APIs. It supports blocking,
+non-blocking, and full-duplex I/O. There are no locks or mutexes.
As it can be difficult to keep track of which encryption algorithms and
protocols are best to use, s2n-tls features a simple API to use the latest
default set of preferences. Remaining on a specific version for backwards
compatibility is also supported.")
(home-page "https://github.com/aws/s2n-tls")
- (license license:asl2.0))))
+ (license license:asl2.0)))
(define-public wolfssl
(package