summaryrefslogtreecommitdiff
path: root/gnu/packages/tls.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-09-17 17:39:30 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-09-17 18:50:00 +0200
commit881006b65cd7693a1f473870fef1ae38f497f9ae (patch)
treee852ab9c0debc15f596fc55e04a03811b2b16c06 /gnu/packages/tls.scm
parent0c19c0f272f89fd94e88f1d7fd8e581b47bad3e7 (diff)
downloadguix-patches-881006b65cd7693a1f473870fef1ae38f497f9ae.tar
guix-patches-881006b65cd7693a1f473870fef1ae38f497f9ae.tar.gz
gnu: certbot: Fix build with python-pyopenssl >= 17.3.0.
* gnu/packages/patches/python-acme-dont-use-openssl-rand.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. * gnu/packages/tls.scm (python-acme)[source]: Use it.
Diffstat (limited to 'gnu/packages/tls.scm')
-rw-r--r--gnu/packages/tls.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index 4b3d766b05..add371ffa3 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -490,9 +490,10 @@ netcat implementation that supports TLS.")
(source (origin
(method url-fetch)
(uri (pypi-uri "acme" version))
- (sha256
- (base32
- "0ry6vhfkhds28sg232hngwfnkqihsxv9r8w92c6nz45r7w56qk0y"))))
+ (patches (search-patches "python-acme-dont-use-openssl-rand.patch"))
+ (sha256
+ (base32
+ "0ry6vhfkhds28sg232hngwfnkqihsxv9r8w92c6nz45r7w56qk0y"))))
(build-system python-build-system)
(arguments
`(#:phases