summaryrefslogtreecommitdiff
path: root/gnu/packages/tls.scm
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2020-11-17 19:28:09 +0000
committerChristopher Baines <mail@cbaines.net>2020-11-17 21:38:06 +0000
commit8a594487700ddd2d6c293cc5e302ce74f3f56b70 (patch)
tree86e3b51dd41fe5eb17c41c203500bf73144f90dc /gnu/packages/tls.scm
parent6877e7f97a244d5e2e53cad0b1494247ac8bf1af (diff)
downloadguix-patches-8a594487700ddd2d6c293cc5e302ce74f3f56b70.tar
guix-patches-8a594487700ddd2d6c293cc5e302ce74f3f56b70.tar.gz
gnu: gnutls: Make p11-kit a propagated input.
Because p11-kit appears in the gnutls.pc file, it needs to be a propagated input. This was a regression introduced in 28a13226fd5cd08b3eb090151c0753424c3f6eb4 which broke things like HTTPS support in curl, which then broke Git clones from repositories using HTTPS. * gnu/packages/tls.scm (gnutls)[inputs]: Move p11-kit from here. [propagated-inputs]: To here.
Diffstat (limited to 'gnu/packages/tls.scm')
-rw-r--r--gnu/packages/tls.scm14
1 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index a3d00703b1..9cb5ac9b85 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -255,18 +255,18 @@ living in the same process.")
`(("datefudge" ,datefudge))) ;tests rely on 'datefudge'
("util-linux" ,util-linux))) ;one test needs 'setsid'
(inputs
- `(("guile" ,guile-3.0)
- ,@(let ((system (or (%current-target-system)
- (%current-system))))
- (if (string-prefix? "mips64el" system)
- '()
- `(("p11-kit" ,p11-kit))))))
+ `(("guile" ,guile-3.0)))
(propagated-inputs
;; These are all in the 'Requires.private' field of gnutls.pc.
`(("libtasn1" ,libtasn1)
("libidn2" ,libidn2)
("nettle" ,nettle)
- ("zlib" ,zlib)))
+ ("zlib" ,zlib)
+ ,@(let ((system (or (%current-target-system)
+ (%current-system))))
+ (if (string-prefix? "mips64el" system)
+ '()
+ `(("p11-kit" ,p11-kit))))))
(home-page "https://www.gnu.org/software/gnutls/")
(synopsis "Transport layer security library")
(description