summaryrefslogtreecommitdiff
path: root/gnu/packages/time.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-02-06 13:03:26 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-02-06 13:03:26 +0100
commitba88eea2b3a8a33ecd7fc0ec64e3917c6c2fe21d (patch)
tree75c68e44d3d76440f416552711b1a47ec83e411e /gnu/packages/time.scm
parentf380f9d55e6757c242acf6c71c4a3ccfcdb066b2 (diff)
parent4aeb7f34c948f32363f2ae29c6942c6328df758c (diff)
downloadguix-patches-ba88eea2b3a8a33ecd7fc0ec64e3917c6c2fe21d.tar
guix-patches-ba88eea2b3a8a33ecd7fc0ec64e3917c6c2fe21d.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/time.scm')
-rw-r--r--gnu/packages/time.scm31
1 files changed, 23 insertions, 8 deletions
diff --git a/gnu/packages/time.scm b/gnu/packages/time.scm
index 895cf6ac3b..e491970300 100644
--- a/gnu/packages/time.scm
+++ b/gnu/packages/time.scm
@@ -2,7 +2,7 @@
;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
;;; Copyright © 2013, 2017 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2013, 2015 Andreas Enge <andreas@enge.fr>
-;;; Copyright © 2015, 2016, 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2015, 2016, 2017, 2018, 2019 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2015, 2017 Leo Famulari <leo@famulari.name>
;;; Copyright © 2015, 2017 Cyril Roelandt <tipecaml@gmail.com>
;;; Copyright © 2016 Sou Bunnbu <iyzsong@gmail.com>
@@ -38,7 +38,8 @@
#:use-module (guix build-system python)
#:use-module (gnu packages check)
#:use-module (gnu packages compression)
- #:use-module (gnu packages python))
+ #:use-module (gnu packages python)
+ #:use-module (gnu packages python-xyz))
(define-public time
(package
@@ -198,17 +199,29 @@ datetime module, available in Python 2.3+.")
(define-public python-tzlocal
(package
(name "python-tzlocal")
- (version "1.2.2")
+ (version "1.5.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "tzlocal" version))
(sha256
(base32
- "0paj7vlsb0np8b5sp4bv64wxv7qk2piyp7xg29pkhdjwsbls9fnb"))))
+ "0kiciwiqx0bv0fbc913idxibc4ygg4cb7f8rcpd9ij2shi4bigjf"))))
(build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'fix-symlink-test
+ ;; see: https://github.com/regebro/tzlocal/issues/53
+ (lambda _
+ (delete-file "tzlocal/test_data/symlink_localtime/etc/localtime")
+ (symlink "../usr/share/zoneinfo/Africa/Harare"
+ "tzlocal/test_data/symlink_localtime/etc/localtime")
+ #t)))))
(propagated-inputs
`(("python-pytz" ,python-pytz)))
+ (native-inputs
+ `(("python-mock" ,python-mock)))
(home-page "https://github.com/regebro/tzlocal")
(synopsis "Local timezone information for Python")
(description
@@ -216,21 +229,23 @@ datetime module, available in Python 2.3+.")
This module attempts to fix a glaring hole in pytz, that there is no way to
get the local timezone information, unless you know the zoneinfo name, and
under several distributions that's hard or impossible to figure out.")
- (license cc0)))
+ (license expat)))
(define-public python-isodate
(package
(name "python-isodate")
- (version "0.5.4")
+ (version "0.6.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "isodate" version))
(sha256
(base32
- "0cafaiwixgpxwh9dsd28qb0dbzsj6xpxjdkyk30ns91ps10mq422"))))
+ "1n7jkz68kk5pwni540pr5zdh99bf6ywydk1p5pdrqisrawylldif"))))
(build-system python-build-system)
- (home-page "http://cheeseshop.python.org/pypi/isodate")
+ (native-inputs
+ `(("python-six" ,python-six)))
+ (home-page "https://github.com/gweis/isodate/")
(synopsis "Python date parser and formatter")
(description
"Python-isodate is a python module for parsing and formatting