summaryrefslogtreecommitdiff
path: root/gnu/packages/textutils.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-12-13 16:29:21 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-12-13 16:29:21 -0500
commit6dffced09ecda024e0884e352778c221ad066fd6 (patch)
tree1707e8d8df4d9c47317a39ab6abbfc2ca66a6c29 /gnu/packages/textutils.scm
parentb603554ed044638dd40b6863d5dada59eefe03b8 (diff)
parente3196755e60ba7f1ed9d432e73f26a85e0c8893c (diff)
downloadguix-patches-6dffced09ecda024e0884e352778c221ad066fd6.tar
guix-patches-6dffced09ecda024e0884e352778c221ad066fd6.tar.gz
Merge branch 'core-updates-frozen' into 'master'.
At last!
Diffstat (limited to 'gnu/packages/textutils.scm')
-rw-r--r--gnu/packages/textutils.scm39
1 files changed, 14 insertions, 25 deletions
diff --git a/gnu/packages/textutils.scm b/gnu/packages/textutils.scm
index 7e7293ac16..2ab0b05d9b 100644
--- a/gnu/packages/textutils.scm
+++ b/gnu/packages/textutils.scm
@@ -22,6 +22,7 @@
;;; Copyright © 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2021 Jean-Baptiste Volatier <jbv@pm.me>
;;; Copyright © 2021 Simon Tournier <zimon.toutoune@gmail.com>
+;;; Copyright © 2021 Felix Gruber <felgru@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -111,8 +112,7 @@ to DOS format and vice versa.")
(base32 "0m59sd1ca0zw1aydpc3m8sw03nc885knmccqryg7byzmqs585ia6"))))
(build-system gnu-build-system)
(native-inputs
- `(("python" ,python)
- ("python-cython" ,python-cython)))
+ (list python python-cython))
(home-page "https://github.com/rrthomas/recode")
(synopsis "Text encoding converter")
(description "The Recode library converts files between character sets and
@@ -417,7 +417,7 @@ input bits thoroughly but are not suitable for cryptography.")
(base32 "0dc9fxcdmppbs9s06jvq61zbk552laxps0xyk098gj41697ihd96"))))
(build-system gnu-build-system)
(native-inputs
- `(("gettext" ,gettext-minimal)))
+ (list gettext-minimal))
(home-page "https://billposer.org/Software/a2b.html")
(synopsis "Convert between ASCII, hexadecimal and binary representations")
(description "The two programs are useful for generating test data, for
@@ -475,8 +475,7 @@ useful when it is desired to reformat numbers.
(("^iconv ") (string-append iconv "/bin/iconv ")))
#t))))))
(inputs
- `(("ascii2binary" ,ascii2binary)
- ("libiconv" ,libiconv)))
+ (list ascii2binary libiconv))
(home-page "https://billposer.org/Software/unidesc.html")
(synopsis "Find out what is in a Unicode file")
(description "Useful tools when working with Unicode files when one
@@ -750,15 +749,9 @@ in a portable way.")
(invoke "autoreconf" "-vif")
#t)))))
(inputs
- `(("ncurses" ,ncurses)
- ("perl" ,perl)
- ("readline" ,readline)
- ("slang" ,slang)))
+ (list ncurses perl readline slang))
(native-inputs
- `(("libtool" ,libtool)
- ("autoconf" ,autoconf)
- ("automake" ,automake)
- ("pkg-config" ,pkg-config)))
+ (list libtool autoconf automake pkg-config))
(home-page "https://www.lbreyer.com/dbacl.html")
(synopsis "Bayesian text and email classifier")
(description
@@ -794,9 +787,7 @@ categories.")
(build-system gnu-build-system)
(arguments `(#:tests? #f)) ; FIXME maketest.sh does not work.
(native-inputs
- `(("autoconf" ,autoconf)
- ("automake" ,automake)
- ("libtool" ,libtool)))
+ (list autoconf automake libtool))
(home-page "https://github.com/williamh/dotconf")
(synopsis "Configuration file parser library")
(description
@@ -853,8 +844,8 @@ categories.")
(with-directory-excursion
(format #f "../drm_tools-~a" ,version)
(invoke "sh" "test_all.sh")))))))))
- (native-inputs `(("which" ,which))) ;for tests
- (inputs `(("pcre" ,pcre)))
+ (native-inputs (list which)) ;for tests
+ (inputs (list pcre))
(home-page "http://drmtools.sourceforge.net/")
(synopsis "Utilities to manipulate text and binary files")
(description "The drm_tools package contains the following commands:
@@ -929,8 +920,7 @@ Filter, list, or split a tar file.
#:tests? #f
#:jar-name "rsyntaxtextarea.jar"))
(native-inputs
- `(("java-junit" ,java-junit)
- ("java-hamcrest-core" ,java-hamcrest-core)))
+ (list java-junit java-hamcrest-core))
(home-page "https://bobbylight.github.io/RSyntaxTextArea/")
(synopsis "Syntax highlighting text component for Java Swing")
(description "RSyntaxTextArea is a syntax highlighting, code folding text
@@ -969,7 +959,7 @@ source code.")
(delete-file "bycython.cpp")
(invoke "cython" "--cplus" "bycython.pyx")))))))
(native-inputs
- `(("python-cython" ,python-cython)))
+ (list python-cython))
(home-page "https://www.github.com/aflc/editdistance")
(synopsis "Fast implementation of the edit distance (Levenshtein distance)")
(description
@@ -1019,8 +1009,7 @@ text.")
"06vdikjvpj6qdb41d8wzfnyj44jpnknmlgbhbr1w215420lpb5xj"))))
(build-system gnu-build-system)
(inputs
- `(("unzip" ,unzip)
- ("perl" ,perl)))
+ (list unzip perl))
(arguments
`(#:tests? #f ; No tests.
#:make-flags (list (string-append "BINDIR="
@@ -1132,7 +1121,7 @@ documents into plain text.")
;; no configure script
(delete 'configure))))
(inputs
- `(("zlib" ,zlib)))
+ (list zlib))
(home-page "https://github.com/dstosberg/odt2txt/")
(synopsis "Converter from OpenDocument Text to plain text")
(description "odt2txt is a command-line tool which extracts the text out
@@ -1210,7 +1199,7 @@ OpenDocument presentations (*.odp).")
(chdir "python")
(mkdir-p dist)
(setenv "PYTHONPATH"
- (string-append dist ":" (getenv "PYTHONPATH")))
+ (string-append dist ":" (getenv "GUIX_PYTHONPATH")))
(invoke "python" "setup.py" "install"
"--root=/" "--single-version-externally-managed"
(string-append "--prefix=" out))