summaryrefslogtreecommitdiff
path: root/gnu/packages/textutils.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-10-10 22:33:28 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-10-10 22:33:28 +0200
commitc01ef97594a8b06e884906a5efbdfacf8ba33dc3 (patch)
tree828b4711c6ad71ab8fc9b6fc8f23f80979c5fe9b /gnu/packages/textutils.scm
parent86d02fa8010c053ba980e4c39373b9bf8af0561d (diff)
parent4b8b4418e609b5e0bfb6efbc11ac28deaa437e80 (diff)
downloadguix-patches-c01ef97594a8b06e884906a5efbdfacf8ba33dc3.tar
guix-patches-c01ef97594a8b06e884906a5efbdfacf8ba33dc3.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/textutils.scm')
-rw-r--r--gnu/packages/textutils.scm25
1 files changed, 12 insertions, 13 deletions
diff --git a/gnu/packages/textutils.scm b/gnu/packages/textutils.scm
index 3359ab4845..2007a25d93 100644
--- a/gnu/packages/textutils.scm
+++ b/gnu/packages/textutils.scm
@@ -97,15 +97,15 @@ to DOS format and vice versa.")
(native-inputs `(("python" ,python-2)))
(arguments
'(#:phases
- (alist-cons-before
- 'check 'pre-check
- (lambda _
- (substitute* "tests/setup.py"
- (("([[:space:]]*)include_dirs=.*" all space)
- (string-append all space "library_dirs=['../src/.libs'],\n")))
- ;; The test extension 'Recode.so' lacks RUNPATH for 'librecode.so'.
- (setenv "LD_LIBRARY_PATH" (string-append (getcwd) "/src/.libs")))
- %standard-phases)))
+ (modify-phases %standard-phases
+ (add-before 'check 'pre-check
+ (lambda _
+ (substitute* "tests/setup.py"
+ (("([[:space:]]*)include_dirs=.*" all space)
+ (string-append all space "library_dirs=['../src/.libs'],\n")))
+ ;; The test extension 'Recode.so' lacks RUNPATH for 'librecode.so'.
+ (setenv "LD_LIBRARY_PATH" (string-append (getcwd) "/src/.libs"))
+ #t)))))
(home-page "https://github.com/pinard/Recode")
(synopsis "Text encoding converter")
(description "The Recode library converts files between character sets and
@@ -208,10 +208,9 @@ encoding, supporting Unicode version 9.0.0.")
(build-system gnu-build-system)
(arguments
'(#:phases
- (alist-cons-after
- 'unpack 'autoreconf
- (lambda _ (zero? (system* "autoreconf" "-vif")))
- %standard-phases)))
+ (modify-phases %standard-phases
+ (add-after 'unpack 'autoreconf
+ (lambda _ (zero? (system* "autoreconf" "-vif")))))))
(native-inputs
`(("autoconf" ,autoconf)
("automake" ,automake)