summaryrefslogtreecommitdiff
path: root/gnu/packages/text-editors.scm
diff options
context:
space:
mode:
authorcalum <calumirwin1@gmail.com>2021-08-29 23:39:14 +1200
committerLars-Dominik Braun <lars@6xq.net>2021-08-31 14:08:17 +0200
commit9af83d1cf98da8353a582c5cab62c2b01d7f8dc3 (patch)
tree1bafa09e6fc3c99cf9036e08c1805ea52bc8624d /gnu/packages/text-editors.scm
parent222f4661ed11b225f458cbe495a296f233129bec (diff)
downloadguix-patches-9af83d1cf98da8353a582c5cab62c2b01d7f8dc3.tar
guix-patches-9af83d1cf98da8353a582c5cab62c2b01d7f8dc3.tar.gz
gnu: kakoune: Update to v2021.08.28
* gnu/packages/text-editors.scm (kakoune): Update to v2021.08.28 [native-inputs]: Use gcc-10. [inputs]: Remove ncurses dependancy. Signed-off-by: Lars-Dominik Braun <lars@6xq.net>
Diffstat (limited to 'gnu/packages/text-editors.scm')
-rw-r--r--gnu/packages/text-editors.scm10
1 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/text-editors.scm b/gnu/packages/text-editors.scm
index 2074442da5..79d2ec4f68 100644
--- a/gnu/packages/text-editors.scm
+++ b/gnu/packages/text-editors.scm
@@ -16,6 +16,7 @@
;;; Copyright © 2021 aecepoglu <aecepoglu@fastmail.fm>
;;; Copyright © 2021 Leo Famulari <leo@famulari.name>
;;; Copyright © 2021 Pierre Langlois <pierre.langlois@gmx.com>
+;;; Copyright © 2021 Calum Irwin <calumirwin1@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -163,7 +164,7 @@ based command language.")
(define-public kakoune
(package
(name "kakoune")
- (version "2020.09.01")
+ (version "2021.08.28")
(source
(origin
(method url-fetch)
@@ -171,7 +172,7 @@ based command language.")
"releases/download/v" version "/"
"kakoune-" version ".tar.bz2"))
(sha256
- (base32 "0x81rxy7bqnhd9374g5ypy4w4nxmm0vnqw6b52bf62jxdg2qj6l6"))))
+ (base32 "1jvn4b9rma5jjvg3xz8nf224pbq3ry570j6qvc834wn5v3gxfvkg"))))
(build-system gnu-build-system)
(arguments
`(#:make-flags
@@ -194,11 +195,10 @@ based command language.")
(add-before 'build 'chdir
(lambda _ (chdir "src") #t)))))
(native-inputs
- `(("asciidoc" ,asciidoc)
+ `(("gcc", gcc-10) ; See https://github.com/mawww/kakoune/issues/4318
+ ("asciidoc" ,asciidoc)
("pkg-config" ,pkg-config)
("ruby" ,ruby)))
- (inputs
- `(("ncurses" ,ncurses)))
(synopsis "Vim-inspired code editor")
(description
"Kakoune is a code editor heavily inspired by Vim, as such most of its