summaryrefslogtreecommitdiff
path: root/gnu/packages/text-editors.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-06-19 17:38:47 +0200
committerMarius Bakke <marius@gnu.org>2021-06-19 17:38:47 +0200
commit6f9a80b331ae41d142a49fbeb94b90ee587b6155 (patch)
tree2da042a6ccf5368c73d6e3d54c2ee02a62d284e4 /gnu/packages/text-editors.scm
parent6500c9a5b364616e38a7e03aa4516fc2d7cee876 (diff)
parentdece03e2b98fc1c2428c2448ce5792f813eb79bf (diff)
downloadguix-patches-6f9a80b331ae41d142a49fbeb94b90ee587b6155.tar
guix-patches-6f9a80b331ae41d142a49fbeb94b90ee587b6155.tar.gz
Merge branch 'master' into core-updates
Note: this merge actually changes the 'curl' and 'python-attrs' derivations, as part of solving caf4a7a2770ef4d05a6e18f40d602e51da749ddc and 12964df69a99de6190422c752fef65ef813f3b6b respectively. 4604d43c0e (gnu: gnutls@3.6.16: Fix cross-compilation.) was ignored because it cannot currently be tested. Conflicts: gnu/local.mk gnu/packages/aidc.scm gnu/packages/boost.scm gnu/packages/curl.scm gnu/packages/nettle.scm gnu/packages/networking.scm gnu/packages/python-xyz.scm gnu/packages/tls.scm
Diffstat (limited to 'gnu/packages/text-editors.scm')
-rw-r--r--gnu/packages/text-editors.scm42
1 files changed, 37 insertions, 5 deletions
diff --git a/gnu/packages/text-editors.scm b/gnu/packages/text-editors.scm
index 426a15853d..62b198fd0d 100644
--- a/gnu/packages/text-editors.scm
+++ b/gnu/packages/text-editors.scm
@@ -14,6 +14,7 @@
;;; Copyright © 2020 Mark Meyer <mark@ofosos.org>
;;; Copyright © 2020 Maxime Devos <maximedevos@telenet.be>
;;; Copyright © 2021 aecepoglu <aecepoglu@fastmail.fm>
+;;; Copyright © 2021 Leo Famulari <leo@famulari.name>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -396,6 +397,38 @@ features are implemented in the editor. Leafpad is simple to use, is easily
compiled, requires few libraries, and starts up quickly. ")
(license license:gpl2+)))
+(define-public l3afpad
+ (let ((commit "5235c9e13bbf0d31a902c6776918c2d7cdbb61ff")
+ (revision "0"))
+ (package
+ (name "l3afpad")
+ (version (git-version "0.8.18.1.11" revision commit))
+ (source (origin
+ (method git-fetch)
+ (file-name (git-file-name name version))
+ (uri (git-reference
+ (url "https://github.com/stevenhoneyman/l3afpad")
+ (commit commit)))
+ (sha256
+ (base32
+ "1alyghm2wpakzdfag0g4g8gb1h9l4wdg7mnhq8bk0iq5ryqia16a"))))
+ (build-system glib-or-gtk-build-system)
+ (native-inputs
+ `(("intltool" ,intltool)
+ ("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("gtk+" ,gtk+)))
+ (home-page "http://tarot.freeshell.org/leafpad/")
+ (synopsis "GTK+ 3 based text editor")
+ (description "L3afpad is a GTK+ 3 text editor that emphasizes simplicity. As
+ development focuses on keeping weight down to a minimum, only the most essential
+ features are implemented in the editor. L3afpad is simple to use, is easily
+ compiled, requires few libraries, and starts up quickly. L3afpad is a
+ fork of Leafpad that uses GTK+ 3 instead of GTK+ 2.")
+ (license license:gpl2+))))
+
(define-public e3
(package
(name "e3")
@@ -601,8 +634,7 @@ scripts/input/X11/C/Shell/HTML/Dired): 49KB.
(define-public ghostwriter
(package
(name "ghostwriter")
- ;; XXX We use a release candidate to fix incompatibility with Qt 5.15.
- (version "2.0.0-rc4")
+ (version "2.0.1")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -611,14 +643,14 @@ scripts/input/X11/C/Shell/HTML/Dired): 49KB.
(file-name (git-file-name name version))
(sha256
(base32
- "07547503a209hc0fcg902w3x0s1m899c10nj3gqz3hak0cmrasi3"))))
+ "07jrsh6549zypdnyy7g6yvggrz5mlya9jm7zmkjmvl7s0min3mbc"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)
("qttools" ,qttools))) ; for lrelease
(inputs
`(("hunspell" ,hunspell)
- ("qtbase" ,qtbase)
+ ("qtbase" ,qtbase-5)
("qtdeclarative" ,qtdeclarative)
("qtmultimedia" ,qtmultimedia)
("qtquickcontrols" ,qtquickcontrols)
@@ -825,7 +857,7 @@ editors.")
("guile" ,guile-1.8)
("perl" ,perl)
("python" ,python-wrapper)
- ("qt" ,qtbase)
+ ("qt" ,qtbase-5)
("qtsvg" ,qtsvg)))
(arguments
`(#:tests? #f ; no check target