summaryrefslogtreecommitdiff
path: root/gnu/packages/text-editors.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-03-24 15:28:33 +0200
committerEfraim Flashner <efraim@flashner.co.il>2021-03-24 20:50:44 +0200
commit2aab587f842908a886e3bd08b028885dddd650e0 (patch)
tree87c0723a9ae2c69ab6920d90b6e87ad8510492fe /gnu/packages/text-editors.scm
parent5664bcdcb0e4c10dfe48dd5e4730fc3c746a21e2 (diff)
parent65c46e79e0495fe4d32f6f2725d7233fff10fd70 (diff)
downloadguix-patches-2aab587f842908a886e3bd08b028885dddd650e0.tar
guix-patches-2aab587f842908a886e3bd08b028885dddd650e0.tar.gz
Merge remote-tracking branch 'origin/master' into core-updates
Diffstat (limited to 'gnu/packages/text-editors.scm')
-rw-r--r--gnu/packages/text-editors.scm18
1 files changed, 9 insertions, 9 deletions
diff --git a/gnu/packages/text-editors.scm b/gnu/packages/text-editors.scm
index b86df89af6..91e37b16d7 100644
--- a/gnu/packages/text-editors.scm
+++ b/gnu/packages/text-editors.scm
@@ -80,15 +80,15 @@
(define-public vis
(package
(name "vis")
- (version "0.6") ; also update the vis-test input
+ (version "0.7") ; also update the vis-test input
(source
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/martanne/vis")
+ (url "https://git.sr.ht/~martanne/vis")
(commit (string-append "v" version))))
(sha256
- (base32 "1zjm89cn3rfq8fxpwp66khy53s6vqlmw6q103qyyvix8ydzxdmsh"))
+ (base32 "1g05ncsnk57kcqm9wsv6sz8b24kyzj8r5rfpa1wfwj8qkjzx3vji"))
(file-name (git-file-name name version))))
(build-system gnu-build-system)
(arguments
@@ -136,10 +136,10 @@
,(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/martanne/vis-test")
- (commit "4c4f6645de77f697a45899e8645e0c2bbdc7208a")))
+ (url "https://git.sr.ht/~martanne/vis-test")
+ (commit "bbd2f34ff788e87a51a74069069273ad83c44f1f")))
(sha256
- (base32 "10vh1pxsqw88a5xwh5irkm85xr66dbycmgpmabyw9h0vm14cvcz2"))
+ (base32 "1jsvg2lg3xqfgi79x08kx94mc34mh62ivca10vsci6fqsk68jbd0"))
(file-name (git-file-name "vis-test" version))))))
(inputs `(("lua" ,lua)
("ncurses" ,ncurses)
@@ -807,14 +807,14 @@ editors.")
(define-public texmacs
(package
(name "texmacs")
- (version "1.99.18")
+ (version "1.99.19")
(source
(origin
(method url-fetch)
(uri (string-append "https://www.texmacs.org/Download/ftp/tmftp/"
"source/TeXmacs-" version "-src.tar.gz"))
(sha256
- (base32 "0il3fwgw20421aj90wg8kyhkwk6lbgb3bb2g5qamh5lk90yj725i"))))
+ (base32 "1izwqb0z4gqiglv57mjswk6sjivny73kd2sxrf3nmj7wr12pn5m8"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)
@@ -1048,7 +1048,7 @@ card. It offers:
(substitute* "src/makefile"
(("-lcurses") "-lncurses"))
#t)))))
- (home-page "http://ne.di.unimi.it/")
+ (home-page "https://ne.di.unimi.it/")
(synopsis "Text editor with menu bar")
(description "This package provides a modeless text editor with menu bar.
It supports syntax highlighting, regular expressions, configurable menus,