summaryrefslogtreecommitdiff
path: root/gnu/packages/texinfo.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2020-06-05 10:31:52 +0200
committerMathieu Othacehe <othacehe@gnu.org>2020-06-05 10:31:52 +0200
commitcf0a721e98ca4df7b6ae55312fd77a11c2ed8e51 (patch)
tree7c5d6fc90495b5f00ad166da897fe7aff4f048f0 /gnu/packages/texinfo.scm
parent6503b10bdc18d13d0aca76a9bf7cdb75a89e0adc (diff)
downloadguix-patches-cf0a721e98ca4df7b6ae55312fd77a11c2ed8e51.tar
guix-patches-cf0a721e98ca4df7b6ae55312fd77a11c2ed8e51.tar.gz
gnu: tex-info: Use "perl" input unconditionaly.
* gnu/packages/texinfo.scm (texinfo)[inputs]: Remove a conditional used to avoid a mass rebuild, and always use "perl" input.
Diffstat (limited to 'gnu/packages/texinfo.scm')
-rw-r--r--gnu/packages/texinfo.scm5
1 files changed, 1 insertions, 4 deletions
diff --git a/gnu/packages/texinfo.scm b/gnu/packages/texinfo.scm
index 7dca37b51a..839cd73d6c 100644
--- a/gnu/packages/texinfo.scm
+++ b/gnu/packages/texinfo.scm
@@ -70,10 +70,7 @@
#t)))
%standard-phases)))
(inputs `(("ncurses" ,ncurses)
- ;; TODO: remove `if' in the next rebuild cycle.
- ,@(if (%current-target-system)
- `(("perl" ,perl))
- '())))
+ ("perl" ,perl)))
;; When cross-compiling, texinfo will build some of its own binaries with
;; the native compiler. This means ncurses is needed both in both inputs
;; and native-inputs.