summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-29 16:04:20 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-31 22:07:17 +0200
commitb5bfb452b012b26f868e2fcbac09634faf534a18 (patch)
tree919e853772ce1529578405dd9e91576bf7afa7a9 /gnu/packages/tex.scm
parent03aa57c41f0f4b60839e205ca65e32e3b69181f1 (diff)
downloadguix-patches-b5bfb452b012b26f868e2fcbac09634faf534a18.tar
guix-patches-b5bfb452b012b26f868e2fcbac09634faf534a18.tar.gz
gnu: Add texlive-vdmlisting.
* gnu/packages/tex.scm (texlive-vdmlisting): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 925452da8a..4fac335ed6 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -99256,6 +99256,29 @@ can have variable or fixed height and can be paragraph-cells or inline-cells.
Different vertical alignments can be used in the same row.")
(license license:lppl1.3c)))
+(define-public texlive-vdmlisting
+ (package
+ (name "texlive-vdmlisting")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/vdmlisting/"
+ "tex/latex/vdmlisting/")
+ (base32
+ "0yhgql2gflygjhx5mz87qqyiny7j0wpiqs2yvpmzm57linna3vzn")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/vdmlisting")
+ (synopsis "Typesetting VDM in ASCII syntax")
+ (description
+ "The package is an extension for the @code{listings} package that provides
+a source code printer for LaTeX. This package defines new language
+definitions and listing environments for the three language dialects of the
+Vienna Development Method: VDM-SL, VDM-PP and VDM-RT. If one wants to typeset
+VDM with a mathematical syntax instead of the ASCII syntax used here, one
+should use the @code{vdm} pacakge instead.")
+ (license license:lppl1.3+)))
+
;;;
;;; Avoid adding new packages to the end of this file. To reduce the chances
;;; of a merge conflict, place them above by existing packages with similar