summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-29 16:04:50 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-31 22:07:28 +0200
commita976e821d2d80f1393f9c05adfa1fd6151f2c24a (patch)
tree3a77610f5966b21e30c90dbe53734a13a1d162e5 /gnu/packages/tex.scm
parent66f6ff2aa75804efe603e251a50ed645ffea3f88 (diff)
downloadguix-patches-a976e821d2d80f1393f9c05adfa1fd6151f2c24a.tar
guix-patches-a976e821d2d80f1393f9c05adfa1fd6151f2c24a.tar.gz
gnu: Add texlive-withargs.
* gnu/packages/tex.scm (texlive-withargs): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index bca00f2f70..e4b42937ce 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -99789,6 +99789,26 @@ annotated node trees, and @code{toklist}, which is an implementation of
Knuth's token list macros, to be found on pp.378--379 of the @emph{TeXbook}.")
(license license:lppl)))
+(define-public texlive-withargs
+ (package
+ (name "texlive-withargs")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/withargs/" "tex/latex/withargs/")
+ (base32
+ "06zyvaldbwf80hijp3526qyyrfrbj6zc03fw5pan38gxhin270hg")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/withargs")
+ (synopsis "In-place argument substitution")
+ (description
+ "The @code{\\withargs} command provides a clean way to populate
+a template (containing @samp{#1}, @samp{#2}, etc.) using LaTeX argument
+substitution. It also allows you to carefully control argument expansion
+using a LaTeX3-style argument specification.")
+ (license license:lppl1.3+)))
+
;;;
;;; Avoid adding new packages to the end of this file. To reduce the chances
;;; of a merge conflict, place them above by existing packages with similar