summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-29 16:04:35 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-31 22:07:22 +0200
commita8974cd458cc0a707376d50f165123c9b3b331e2 (patch)
treeda7c112011b547da59fafc49ed83598dd97b2b24 /gnu/packages/tex.scm
parentddb3572169925d086a20347d92b50b4972299d3d (diff)
downloadguix-patches-a8974cd458cc0a707376d50f165123c9b3b331e2.tar
guix-patches-a8974cd458cc0a707376d50f165123c9b3b331e2.tar.gz
gnu: Add texlive-vmargin.
* gnu/packages/tex.scm (texlive-vmargin): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 44fbeda37a..a8fd6b4f20 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -99510,6 +99510,31 @@ containing text. You can use the usual operations to create the union of sets
or the intersection of sets etc.")
(license license:lppl1.2+)))
+(define-public texlive-vmargin
+ (package
+ (name "texlive-vmargin")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/vmargin/" "source/latex/vmargin/"
+ "tex/latex/vmargin/")
+ (base32
+ "0548wbh05b6ga8fxvarmsai8kzadcgix5zkh5l4a4ym4lsdgb47l")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/vmargin")
+ (synopsis "Set various page dimensions")
+ (description
+ "This package provides a macro to set various margins as well as dimensions
+for header/footer and page dimensions. Most common paper sizes, paper
+orientation, disabling of headers and footers, and two sided printing are
+supported.
+
+The user interface might not be very fancy, but it's fast, small, and gets the
+job done. If you are looking for something more elaborate try the
+@code{geometry} package.")
+ (license license:lppl)))
+
;;;
;;; Avoid adding new packages to the end of this file. To reduce the chances
;;; of a merge conflict, place them above by existing packages with similar