summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-29 16:04:21 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-31 22:07:18 +0200
commit9d19f7789a833684d9edf5cbee5b7744d53728b6 (patch)
tree25e8ccc84a50813f92056f3059080aae677914ae /gnu/packages/tex.scm
parentb5bfb452b012b26f868e2fcbac09634faf534a18 (diff)
downloadguix-patches-9d19f7789a833684d9edf5cbee5b7744d53728b6.tar
guix-patches-9d19f7789a833684d9edf5cbee5b7744d53728b6.tar.gz
gnu: Add texlive-verbasef.
* gnu/packages/tex.scm (texlive-verbasef): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 4fac335ed6..3faef63686 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -99279,6 +99279,28 @@ VDM with a mathematical syntax instead of the ASCII syntax used here, one
should use the @code{vdm} pacakge instead.")
(license license:lppl1.3+)))
+(define-public texlive-verbasef
+ (package
+ (name "texlive-verbasef")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/verbasef/" "tex/latex/verbasef/")
+ (base32
+ "0qs4142zgygcp7yl69mz1i92plnkkp61qb1icjzpw8g7myxyhn9a")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/verbasef")
+ (synopsis "VERBatim Automatic Splitting of External Files")
+ (description
+ "The package allows you to input (subsections of a) file, print them in
+verbatim mode, while automatically breaking up the input lines into pieces of
+a given length, which are output as figures. These figures are posted using
+the @samp{[H]} specification, which forces LaTeX to place the figure at the
+spot of invocation, rather than floating the figures to the top of the next
+page.")
+ (license license:gpl3+)))
+
;;;
;;; Avoid adding new packages to the end of this file. To reduce the chances
;;; of a merge conflict, place them above by existing packages with similar