summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-29 16:04:43 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-31 22:07:25 +0200
commit7d3aa43b55dd2a5a01c9f29955f3a4aabe6c7c0f (patch)
tree542b1fc5310580d78a25b2440413fdc0c71e6db0 /gnu/packages/tex.scm
parent132dd19a8e9aea5170143d98b47fe4dcff5fef95 (diff)
downloadguix-patches-7d3aa43b55dd2a5a01c9f29955f3a4aabe6c7c0f.tar
guix-patches-7d3aa43b55dd2a5a01c9f29955f3a4aabe6c7c0f.tar.gz
gnu: Add texlive-warning.
* gnu/packages/tex.scm (texlive-warning): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 17d4a1ac79..21293375a1 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -99660,6 +99660,25 @@ for internationalization. There is also support for loading event marks from
a CSV file.")
(license license:lppl)))
+(define-public texlive-warning
+ (package
+ (name "texlive-warning")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/warning/" "tex/latex/warning/")
+ (base32
+ "0d259bpnv7qgki5cmf0w12gqxiw9ww0901j13lm30b1myxhy0giq")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/warning")
+ (synopsis "Global warnings at the end of the logfile")
+ (description
+ "This package provides a command that generates a list of warnings that are
+printed out at the very end of the logfile. This is useful for warnings such
+as ``Rerun for this or that reason'' or ``This is a draft''.")
+ (license license:lppl)))
+
;;;
;;; Avoid adding new packages to the end of this file. To reduce the chances
;;; of a merge conflict, place them above by existing packages with similar