summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-29 16:04:47 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-31 22:07:27 +0200
commit5f0b72bf40a950af1b3d353f4179a16d97214416 (patch)
tree71e9cbd048bf17da2daad715902d122fc2aa9370 /gnu/packages/tex.scm
parent6c4ff91995dd45ba18ca8287e42c2c5f1d01fd94 (diff)
downloadguix-patches-5f0b72bf40a950af1b3d353f4179a16d97214416.tar
guix-patches-5f0b72bf40a950af1b3d353f4179a16d97214416.tar.gz
gnu: Add texlive-widetable.
* gnu/packages/tex.scm (texlive-widetable): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 74cc822ee5..e282f1eb62 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -99725,6 +99725,27 @@ files using @command{webquiz}, which is written in Python. The conversion
from LaTeX to HTML is done behind the scenes using TeX4ht.")
(license license:gpl3+)))
+(define-public texlive-widetable
+ (package
+ (name "texlive-widetable")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/widetable/"
+ "source/latex/widetable/"
+ "tex/latex/widetable/")
+ (base32
+ "1fb1545agxpkd4xjh6hs70flqpwna13rh5kzc202w64jxsfgwwzs")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/widetable")
+ (synopsis "Environment for typesetting tables of specified width")
+ (description
+ "The package defines a new environment that, unlike tabularX, typesets a table
+of specified width by working on the inter-column glue; the tabular cells will
+all be stretched (or shrunk) according to need.")
+ (license license:lppl1.3+)))
+
;;;
;;; Avoid adding new packages to the end of this file. To reduce the chances
;;; of a merge conflict, place them above by existing packages with similar