summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-29 16:04:25 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-31 22:07:19 +0200
commit4efbb55096094686775b59a3efff0f8350b1c4c8 (patch)
treeaad316ef683e0d35f488b7861cecafdf52655bde /gnu/packages/tex.scm
parent84896144908da605bab7e529977607ef9c37301b (diff)
downloadguix-patches-4efbb55096094686775b59a3efff0f8350b1c4c8.tar
guix-patches-4efbb55096094686775b59a3efff0f8350b1c4c8.tar.gz
gnu: Add texlive-verbments.
* gnu/packages/tex.scm (texlive-verbments): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 38c8b6a2db..27310093e2 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -99345,6 +99345,26 @@ since the defined command is robust, it doesn't matter if the argument is
moving.")
(license license:lppl)))
+(define-public texlive-verbments
+ (package
+ (name "texlive-verbments")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/verbments/"
+ "tex/latex/verbments/")
+ (base32
+ "0lsxr6mibc8v8wfabdph5mnf8zf77yk6s0qnz5p85g9z2fdvpgvf")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/verbments")
+ (synopsis "Syntax highlighting of source code in LaTeX documents")
+ (description
+ "The package provides an environment for syntax highlighting source code in
+LaTeX documents. The highlighted source code output is formatted via Pygments
+library of the Python language.")
+ (license license:lppl1.2+)))
+
;;;
;;; Avoid adding new packages to the end of this file. To reduce the chances
;;; of a merge conflict, place them above by existing packages with similar